Bug#539681: asterisk: Segmentation fault when accepting sip call

Micha M. mtm15 at web.de
Sun Aug 2 19:39:47 UTC 2009

Package: asterisk
Version: 1:
Severity: important

I have 2 sip clients (software). If I call from one (2000) the other (2001)
and then accept the incomming call asterisk 1.6.2 crashes:

*CLI>   == Using SIP RTP CoS mark 5
    -- Executing [2001 at default:1] Dial("SIP/2000-0a11c618", "SIP/2001") in new stack
  == Using SIP RTP CoS mark 5
    -- Called 2001
    -- SIP/2001-0a13dbb0 is ringing
    -- SIP/2001-0a13dbb0 answered SIP/2000-0a11c618
    -- Native bridging SIP/2000-0a11c618 and SIP/2001-0a13dbb0
Segmentation fault

The problem is reprodueceable.



-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (900, 'testing'), (700, 'unstable')
Architecture: i386 (i686)

Kernel: Linux 2.6.26-2-686 (SMP w/1 CPU core)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages asterisk depends on:
ii  adduser           3.110                  add and remove users and groups
ii  asterisk-config   1: Configuration files for Asterisk
ii  asterisk-sounds-m 1:      Core Sound files for Asterisk (Eng
ii  dahdi             1:2.2.0~rc3-1          utilities for using the DAHDI kern
ii  libasound2        1.0.20-2               shared library for ALSA applicatio
ii  libc6             2.9-12                 GNU C Library: Shared libraries
ii  libcap2           1:2.16-5               support for getting/setting POSIX.
ii  libcurl3          7.19.5-1               Multi-protocol file transfer libra
ii  libgcc1           1:4.4.0-5              GCC support library
ii  libglib2.0-0      2.20.1-2               The GLib library of C routines
ii  libgmime-2.0-2a   2.2.22-4               MIME library
ii  libgsm1           1.0.12-1               Shared libraries for GSM speech co
ii  libiksemel3       1.2-4                  C library for the Jabber IM platfo
ii  libldap-2.4-2     2.4.11-1               OpenLDAP libraries
ii  liblua5.1-0       5.1.4-3                Simple, extensible, embeddable pro
ii  libncurses5       5.7+20090523-1         shared libraries for terminal hand
ii  libnewt0.52       0.52.10-4              Not Erik's Windowing Toolkit - tex
ii  libogg0           1.1.3-5                Ogg Bitstream Library
ii  libopenais2       0.83-1                 Standards-based cluster framework 
ii  libpopt0          1.14-4                 lib for parsing cmdline parameters
ii  libpq5            8.4.0-2                PostgreSQL C client library
ii  libpri1.4         1.4.10-1               Primary Rate ISDN specification li
ii  libradiusclient-n 0.5.6-1                Enhanced RADIUS client library
ii  libsdl1.2debian   1.2.13-4+b1            Simple DirectMedia Layer
ii  libsnmp15         5.4.1~dfsg-12          SNMP (Simple Network Management Pr
ii  libspandsp1       0.0.5~pre4-1           Telephony signal processing librar
ii  libspeex1         1.2~rc1-1              The Speex codec runtime library
ii  libspeexdsp1      1.2~rc1-1              The Speex extended runtime library
ii  libsqlite0        2.8.17-4               SQLite shared library
ii  libss7-1          1.0.2-1                Signalling System 7 (ss7) library
ii  libssl0.9.8       0.9.8k-3               SSL shared libraries
ii  libstdc++6        4.4.0-5                The GNU Standard C++ Library v3
ii  libsybdb5         0.82-5                 libraries for connecting to MS SQL
ii  libtiff4          3.8.2-13               Tag Image File Format (TIFF) libra
ii  libtonezone2.0    1:2.2.0~rc3-1          tonezone library (runtime)
ii  libvorbis0a       1.2.0.dfsg-5           The Vorbis General Audio Compressi
ii  libvorbisenc2     1.2.0.dfsg-5           The Vorbis General Audio Compressi
ii  libvpb0           4.2.42-1               Voicetronix telephony hardware use
ii  libx11-6          2:1.2.2-1              X11 client-side library
ii  libxml2           2.7.3.dfsg-2           GNOME XML library
ii  unixodbc          2.2.11-16+b1           ODBC tools libraries
ii  zlib1g            1:      compression library - runtime

asterisk recommends no packages.

Versions of packages asterisk suggests:
ii  asterisk-dev           1: Development files for Asterisk
pn  asterisk-doc           <none>            (no description available)
pn  asterisk-h323          <none>            (no description available)
pn  ekiga                  <none>            (no description available)
pn  kphone                 <none>            (no description available)
pn  ohphone                <none>            (no description available)
pn  twinkle                <none>            (no description available)

-- no debconf information

More information about the Pkg-voip-maintainers mailing list