Bug#575195: opal should build-depend on libsrtp-dev, and libopal-dev should depend on libsrtp0-dev

Mark Purcell msp at debian.org
Sat May 15 10:03:25 UTC 2010

On Saturday 15 May 2010 07:22:55 Eugen Dedu wrote:
> I still do not understand, could you please elaborate?  On the system 
> where libopal is linked to srtp, libopal-dev too uses srtp.

Opal .debs get built on a machine (user, binNMU, buildd) with srtp-dev 

These .debs then get installed on a machine without srtp-dev. You would be 
surprised how often this can occur. No deps automatically pull in srtp libs.

User then builds an application with opal, however as srpt is missing build 
fails, both headers and libs...


1. Make explicit Build-Depends: libsrtp-dev, then it is expected that all 
.debs will include depends, and when the package above are installed they srtp 
deps will be pulled in.  packages are working as expected...

2. Make explicit Build-Conflicts: libsrtp-dev, then it is expected that all 
.debs will not depend on srtp.  If a user wants to include srtp support, then 
they need to change the package configuration and we can claim it is 

Thus the recommend that we go for option 1.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part.
URL: <http://lists.alioth.debian.org/pipermail/pkg-voip-maintainers/attachments/20100515/f4e32bed/attachment.pgp>

More information about the Pkg-voip-maintainers mailing list