[SCM] WebKit Debian packaging branch, debian/unstable, updated. debian/1.1.15-1-40151-g37bb677

darin darin at 268f45cc-cd09-0410-ab3c-d52691b4dbfc
Sat Sep 26 07:44:52 UTC 2009


The following commit has been merged in the debian/unstable branch:
commit 5c8408f19ff233f2644ee6d115cf858db8bd527c
Author: darin <darin at 268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Date:   Tue Jun 10 21:00:16 2003 +0000

            Reviewed by John.
    
    	- fixed 3285820 -- REGRESSION: iframe set up with innerHTML shows up empty (discovered at www.kbs.co.kr)
    
            * kwq/KWQKHTMLPart.mm: (KHTMLPart::frameDetached): Remove the frame from the parent's
            m_frames list so it's not accidentally reused, since our naming scheme gives frames in
            the same place in the scheme of things the same name.
    
    
    git-svn-id: http://svn.webkit.org/repository/webkit/trunk@4515 268f45cc-cd09-0410-ab3c-d52691b4dbfc

diff --git a/WebCore/ChangeLog-2003-10-25 b/WebCore/ChangeLog-2003-10-25
index c599e10..f7ffa32 100644
--- a/WebCore/ChangeLog-2003-10-25
+++ b/WebCore/ChangeLog-2003-10-25
@@ -1,3 +1,13 @@
+2003-06-10  Darin Adler  <darin at apple.com>
+
+        Reviewed by John.
+
+	- fixed 3285820 -- REGRESSION: iframe set up with innerHTML shows up empty (discovered at www.kbs.co.kr)
+
+        * kwq/KWQKHTMLPart.mm: (KHTMLPart::frameDetached): Remove the frame from the parent's
+        m_frames list so it's not accidentally reused, since our naming scheme gives frames in
+        the same place in the scheme of things the same name.
+
 2003-06-10  David Hyatt  <hyatt at apple.com>
 
 	Fix for 3270813, crash in the code for the CSS content property.
diff --git a/WebCore/ChangeLog-2005-08-23 b/WebCore/ChangeLog-2005-08-23
index c599e10..f7ffa32 100644
--- a/WebCore/ChangeLog-2005-08-23
+++ b/WebCore/ChangeLog-2005-08-23
@@ -1,3 +1,13 @@
+2003-06-10  Darin Adler  <darin at apple.com>
+
+        Reviewed by John.
+
+	- fixed 3285820 -- REGRESSION: iframe set up with innerHTML shows up empty (discovered at www.kbs.co.kr)
+
+        * kwq/KWQKHTMLPart.mm: (KHTMLPart::frameDetached): Remove the frame from the parent's
+        m_frames list so it's not accidentally reused, since our naming scheme gives frames in
+        the same place in the scheme of things the same name.
+
 2003-06-10  David Hyatt  <hyatt at apple.com>
 
 	Fix for 3270813, crash in the code for the CSS content property.
diff --git a/WebCore/kwq/KWQKHTMLPart.mm b/WebCore/kwq/KWQKHTMLPart.mm
index 1289133..538b0b9 100644
--- a/WebCore/kwq/KWQKHTMLPart.mm
+++ b/WebCore/kwq/KWQKHTMLPart.mm
@@ -564,6 +564,16 @@ void KWQKHTMLPart::addData(const char *bytes, int length)
 void KHTMLPart::frameDetached()
 {
     [KWQ(this)->bridge() frameDetached];
+
+    // FIXME: There may be a better place to do this that works for KHTML too.
+    FrameList& parentFrames = parentPart()->d->m_frames;
+    FrameIt end = parentFrames.end();
+    for (FrameIt it = parentFrames.begin(); it != end; ++it) {
+        if ((*it).m_part == this) {
+            parentFrames.remove(it);
+            break;
+        }
+    }
 }
 
 void KWQKHTMLPart::urlSelected(const KURL &url, int button, int state, const URLArgs &args)

-- 
WebKit Debian packaging



More information about the Pkg-webkit-commits mailing list