[SCM] WebKit Debian packaging branch, debian/unstable, updated. debian/1.1.15-1-40151-g37bb677

sullivan sullivan at 268f45cc-cd09-0410-ab3c-d52691b4dbfc
Sat Sep 26 07:45:54 UTC 2009


The following commit has been merged in the debian/unstable branch:
commit 82ba30e3415dc4399e47e02c55354d23dd406726
Author: sullivan <sullivan at 268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Date:   Mon Jun 30 18:54:51 2003 +0000

    Tests:
    
    	- fixed gcc3.3 incompatibility
    
            Reviewed by Darin
    
            * WebFoundation-Misc/ifnsstringextensions-test.m:
            (main):
    	added "LL" to end of long integer constants
    
    WebCore:
    
    	- fixed gcc3.3 incompatibility
    
            Reviewed by Darin
    
            * kwq/KWQComboBox.mm:
            (QComboBox::updateCurrentItem):
    	cast result of getView() in a local variable to work around
    	compiler bug where casting in a method call doesn't work (all other
    	callers of getView() in this file were already using a local
    	variable)
    
    WebBrowser:
    
    	- fixed gcc3.3 incompatibility
    
            Reviewed by Darin
    
            * Button.h:
    	change name of class from Button to ButtonPlus to avoid conflict
    	with Carbon's Button() function.
            * Button.m:
    	ditto
            * RolloverTrackingButton.h:
    	ditto
    
    
    git-svn-id: http://svn.webkit.org/repository/webkit/trunk@4568 268f45cc-cd09-0410-ab3c-d52691b4dbfc

diff --git a/WebCore/ChangeLog-2003-10-25 b/WebCore/ChangeLog-2003-10-25
index 170fa5c..7220962 100644
--- a/WebCore/ChangeLog-2003-10-25
+++ b/WebCore/ChangeLog-2003-10-25
@@ -1,3 +1,16 @@
+2003-06-30  John Sullivan  <sullivan at apple.com>
+
+	- fixed gcc3.3 incompatibility
+
+        Reviewed by Darin
+
+        * kwq/KWQComboBox.mm:
+        (QComboBox::updateCurrentItem):
+	cast result of getView() in a local variable to work around
+	compiler bug where casting in a method call doesn't work (all other
+	callers of getView() in this file were already using a local
+	variable)
+
 2003-06-26  Chris Blumenberg  <cblu at apple.com>
 
 	More changes to make WebKit and WebCore compile with gcc 3.3.
diff --git a/WebCore/ChangeLog-2005-08-23 b/WebCore/ChangeLog-2005-08-23
index 170fa5c..7220962 100644
--- a/WebCore/ChangeLog-2005-08-23
+++ b/WebCore/ChangeLog-2005-08-23
@@ -1,3 +1,16 @@
+2003-06-30  John Sullivan  <sullivan at apple.com>
+
+	- fixed gcc3.3 incompatibility
+
+        Reviewed by Darin
+
+        * kwq/KWQComboBox.mm:
+        (QComboBox::updateCurrentItem):
+	cast result of getView() in a local variable to work around
+	compiler bug where casting in a method call doesn't work (all other
+	callers of getView() in this file were already using a local
+	variable)
+
 2003-06-26  Chris Blumenberg  <cblu at apple.com>
 
 	More changes to make WebKit and WebCore compile with gcc 3.3.
diff --git a/WebCore/kwq/KWQComboBox.mm b/WebCore/kwq/KWQComboBox.mm
index 7ea3dc3..9f40c9f 100644
--- a/WebCore/kwq/KWQComboBox.mm
+++ b/WebCore/kwq/KWQComboBox.mm
@@ -191,7 +191,8 @@ void QComboBox::setCurrentItem(int index)
 
 bool QComboBox::updateCurrentItem() const
 {
-    int i = [(KWQPopUpButton *)getView() indexOfSelectedItem];
+    KWQPopUpButton *button = (KWQPopUpButton *)getView();
+    int i = [button indexOfSelectedItem];
     if (_currentItem == i) {
         return false;
     }

-- 
WebKit Debian packaging



More information about the Pkg-webkit-commits mailing list