[SCM] WebKit Debian packaging branch, debian/unstable, updated. debian/1.1.15-1-40151-g37bb677

kocienda kocienda at 268f45cc-cd09-0410-ab3c-d52691b4dbfc
Sat Sep 26 08:41:52 UTC 2009


The following commit has been merged in the debian/unstable branch:
commit 7b43579fddd091bce5cd8d926a9232e25151bc73
Author: kocienda <kocienda at 268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Date:   Tue May 25 21:56:04 2004 +0000

    WebCore:
    
            Reviewed by John
    
            Change postDidChangeSelectionNotification and postDidChangeNotification tp
            respondToChangedSelection and respondToChangedContents, respectively, to
            account for the fact that we do work in these calls other than post a
            notification.
    
            * khtml/khtml_part.cpp:
            (KHTMLPart::notifySelectionChanged): Use new names.
            (KHTMLPart::appliedEditing): Ditto.
            (KHTMLPart::unappliedEditing): Ditto.
            (KHTMLPart::reappliedEditing): Ditto.
            * kwq/KWQKHTMLPart.h: Change name of functions as described.
            * kwq/KWQKHTMLPart.mm:
            (KWQKHTMLPart::respondToChangedSelection): Ditto.
            (KWQKHTMLPart::respondToChangedContents): Ditto.
            * kwq/WebCoreBridge.h: Ditto.
    
    WebKit:
    
            Reviewed by John
    
            Change postDidChangeSelectionNotification and postDidChangeNotification tp
            respondToChangedSelection and respondToChangedContents, respectively, to
            account for the fact that we do work in these calls other than post a
            notification. The need to clear the typing style on both kinds of changes
            inspired the name change.
    
            Add in support to set and access typing style. We don't do anything with it yet
            except store and return it. Using the typing style is still to come.
    
            * WebCoreSupport.subproj/WebBridge.m:
            (-[WebBridge respondToChangedContents]): Change name of functions as described.
            (-[WebBridge respondToChangedSelection]): Change name of functions as described.
            * WebView.subproj/WebView.m:
            (-[WebView dealloc:]): Dealloc typing style ivar.
            (-[WebView setTypingStyle:]): Change to set typing style ivar.
            (-[WebView typingStyle]): Return new typing style ivar.
            * WebView.subproj/WebViewPrivate.h: Add ivar for typing style.
    
    
    git-svn-id: http://svn.webkit.org/repository/webkit/trunk@6687 268f45cc-cd09-0410-ab3c-d52691b4dbfc

diff --git a/WebCore/ChangeLog-2005-08-23 b/WebCore/ChangeLog-2005-08-23
index a0b162b..c870021 100644
--- a/WebCore/ChangeLog-2005-08-23
+++ b/WebCore/ChangeLog-2005-08-23
@@ -1,3 +1,23 @@
+2004-05-25  Ken Kocienda  <kocienda at apple.com>
+
+        Reviewed by John
+
+        Change postDidChangeSelectionNotification and postDidChangeNotification tp
+        respondToChangedSelection and respondToChangedContents, respectively, to
+        account for the fact that we do work in these calls other than post a
+        notification.
+
+        * khtml/khtml_part.cpp:
+        (KHTMLPart::notifySelectionChanged): Use new names.
+        (KHTMLPart::appliedEditing): Ditto.
+        (KHTMLPart::unappliedEditing): Ditto.
+        (KHTMLPart::reappliedEditing): Ditto.
+        * kwq/KWQKHTMLPart.h: Change name of functions as described.
+        * kwq/KWQKHTMLPart.mm:
+        (KWQKHTMLPart::respondToChangedSelection): Ditto.
+        (KWQKHTMLPart::respondToChangedContents): Ditto.
+        * kwq/WebCoreBridge.h: Ditto.
+
 2004-05-25  Maciej Stachowiak  <mjs at apple.com>
 
         Fixed build.
diff --git a/WebCore/khtml/khtml_part.cpp b/WebCore/khtml/khtml_part.cpp
index a61223d..03e20a6 100644
--- a/WebCore/khtml/khtml_part.cpp
+++ b/WebCore/khtml/khtml_part.cpp
@@ -2402,7 +2402,7 @@ void KHTMLPart::notifySelectionChanged(bool closeTyping)
     emitSelectionChanged();
     
 #if APPLE_CHANGES
-    KWQ(this)->postDidChangeSelectionNotification();
+    KWQ(this)->respondToChangedSelection();
 #endif
 }
 
@@ -4949,7 +4949,7 @@ void KHTMLPart::appliedEditing(EditCommand &cmd)
         d->m_lastEditCommand = cmd;
     }
 #if APPLE_CHANGES
-    KWQ(this)->postDidChangeNotification();
+    KWQ(this)->respondToChangedContents();
 #endif
 }
 
@@ -4958,7 +4958,7 @@ void KHTMLPart::unappliedEditing(EditCommand &cmd)
     setSelection(cmd.startingSelection());
 #if APPLE_CHANGES
     KWQ(this)->registerCommandForRedo(cmd);
-    KWQ(this)->postDidChangeNotification();
+    KWQ(this)->respondToChangedContents();
 #endif
     d->m_lastEditCommand = EditCommand::emptyCommand();
 }
@@ -4968,7 +4968,7 @@ void KHTMLPart::reappliedEditing(EditCommand &cmd)
     setSelection(cmd.endingSelection());
 #if APPLE_CHANGES
     KWQ(this)->registerCommandForUndo(cmd);
-    KWQ(this)->postDidChangeNotification();
+    KWQ(this)->respondToChangedContents();
 #endif
     d->m_lastEditCommand = EditCommand::emptyCommand();
 }
diff --git a/WebCore/kwq/KWQKHTMLPart.h b/WebCore/kwq/KWQKHTMLPart.h
index b2382c1..7f0b6e9 100644
--- a/WebCore/kwq/KWQKHTMLPart.h
+++ b/WebCore/kwq/KWQKHTMLPart.h
@@ -281,8 +281,8 @@ public:
     void issueCutCommand();
     void issueCopyCommand();
     void issuePasteCommand();
-    void postDidChangeSelectionNotification();
-    void postDidChangeNotification();
+    void respondToChangedSelection();
+    void respondToChangedContents();
     bool isContentEditable() const;
     bool shouldBeginEditing(const DOM::Range &) const;
     bool shouldEndEditing(const DOM::Range &) const;
diff --git a/WebCore/kwq/KWQKHTMLPart.mm b/WebCore/kwq/KWQKHTMLPart.mm
index fe4fa5c..4990760 100644
--- a/WebCore/kwq/KWQKHTMLPart.mm
+++ b/WebCore/kwq/KWQKHTMLPart.mm
@@ -2973,14 +2973,14 @@ void KWQKHTMLPart::issuePasteCommand()
     [_bridge issuePasteCommand];
 }
 
-void KWQKHTMLPart::postDidChangeSelectionNotification()
+void KWQKHTMLPart::respondToChangedSelection()
 {
-    [_bridge postDidChangeSelectionNotification];
+    [_bridge respondToChangedSelection];
 }
 
-void KWQKHTMLPart::postDidChangeNotification()
+void KWQKHTMLPart::respondToChangedContents()
 {
-    [_bridge postDidChangeNotification];
+    [_bridge respondToChangedContents];
 }
 
 bool KWQKHTMLPart::isContentEditable() const
diff --git a/WebCore/kwq/WebCoreBridge.h b/WebCore/kwq/WebCoreBridge.h
index 05e8555..c7658ed 100644
--- a/WebCore/kwq/WebCoreBridge.h
+++ b/WebCore/kwq/WebCoreBridge.h
@@ -453,8 +453,8 @@ typedef enum {
 - (void)issueCutCommand;
 - (void)issueCopyCommand;
 - (void)issuePasteCommand;
-- (void)postDidChangeSelectionNotification;
-- (void)postDidChangeNotification;
+- (void)respondToChangedSelection;
+- (void)respondToChangedContents;
 - (BOOL)interceptEditingKeyEvent:(NSEvent *)event;
 - (void)setIsSelected:(BOOL)isSelected forView:(NSView *)view;
 - (BOOL)isEditable;
diff --git a/WebKit/ChangeLog b/WebKit/ChangeLog
index f437f77..7a26db5 100644
--- a/WebKit/ChangeLog
+++ b/WebKit/ChangeLog
@@ -1,6 +1,28 @@
 2004-05-25  Ken Kocienda  <kocienda at apple.com>
 
         Reviewed by John
+
+        Change postDidChangeSelectionNotification and postDidChangeNotification tp
+        respondToChangedSelection and respondToChangedContents, respectively, to
+        account for the fact that we do work in these calls other than post a
+        notification. The need to clear the typing style on both kinds of changes
+        inspired the name change.
+
+        Add in support to set and access typing style. We don't do anything with it yet
+        except store and return it. Using the typing style is still to come.
+
+        * WebCoreSupport.subproj/WebBridge.m:
+        (-[WebBridge respondToChangedContents]): Change name of functions as described.
+        (-[WebBridge respondToChangedSelection]): Change name of functions as described.
+        * WebView.subproj/WebView.m:
+        (-[WebView dealloc:]): Dealloc typing style ivar.
+        (-[WebView setTypingStyle:]): Change to set typing style ivar.
+        (-[WebView typingStyle]): Return new typing style ivar.
+        * WebView.subproj/WebViewPrivate.h: Add ivar for typing style.
+
+2004-05-25  Ken Kocienda  <kocienda at apple.com>
+
+        Reviewed by John
         
         Improve _bridgeForCurrentSelection so that it is frame-savvy.
         Fixup setSelectedDOMRange:affinity: so that it uses the right bridge.
diff --git a/WebKit/DOM.subproj/DOMExtensions.h b/WebKit/DOM.subproj/DOMExtensions.h
index e40a116..4acb3cf 100644
--- a/WebKit/DOM.subproj/DOMExtensions.h
+++ b/WebKit/DOM.subproj/DOMExtensions.h
@@ -39,6 +39,8 @@
 - (void)setInnerText:(NSString *)innerText;
 - (NSString *)outerHTML;
 - (void)setOuterHTML:(NSString *)outerHTML;
+- (NSString *)outerText;
+- (void)setOuterText:(NSString *)outerText;
 - (DOMHTMLCollection *)children;
 - (NSString *)contentEditable;
 - (void)setContentEditable:(NSString *)contentEditable;
diff --git a/WebKit/WebCoreSupport.subproj/WebBridge.m b/WebKit/WebCoreSupport.subproj/WebBridge.m
index da41e3d..f9e4c67 100644
--- a/WebKit/WebCoreSupport.subproj/WebBridge.m
+++ b/WebKit/WebCoreSupport.subproj/WebBridge.m
@@ -1193,15 +1193,17 @@ static id <WebFormDelegate> formDelegate(WebBridge *self)
     return applet;
 }
 
-- (void)postDidChangeNotification
+- (void)respondToChangedContents
 {
     [[_frame webView] _updateFontPanel];
+    [[_frame webView] setTypingStyle:nil];
     [[NSNotificationCenter defaultCenter] postNotificationName:WebViewDidChangeNotification object:[_frame webView]];
 }
 
-- (void)postDidChangeSelectionNotification
+- (void)respondToChangedSelection
 {
     [[_frame webView] _updateFontPanel];
+    [[_frame webView] setTypingStyle:nil];
     [[NSNotificationCenter defaultCenter] postNotificationName:WebViewDidChangeSelectionNotification object:[_frame webView]];
 }
 
diff --git a/WebKit/WebView.subproj/WebView.m b/WebKit/WebView.subproj/WebView.m
index 0e07f0a..61fb0ab 100644
--- a/WebKit/WebView.subproj/WebView.m
+++ b/WebKit/WebView.subproj/WebView.m
@@ -157,6 +157,7 @@ NSString *_WebMainFrameURLKey =         @"mainFrameURL";
     [progressItems release];
         
     [mediaStyle release];
+    [typingStyle release];
     
     [super dealloc];
 }
@@ -2469,13 +2470,20 @@ static NSFont *_fontFromStyle(DOMCSSStyleDeclaration *style)
 
 - (void)setTypingStyle:(DOMCSSStyleDeclaration *)style
 {
-    ERROR("unimplemented");
+    // FIXME: We do nothing with this typing style right now other than store it.
+    if (style == _private->typingStyle)
+        return;
+
+    DOMCSSStyleDeclaration *oldStyle = _private->typingStyle;
+    _private->typingStyle = [style retain];
+    if (oldStyle)
+        [oldStyle release];
 }
 
 - (DOMCSSStyleDeclaration *)typingStyle
 {
-    //ERROR("unimplemented");
-    return nil;
+    // FIXME: We do nothing with this typing style right now other than store it.
+    return _private->typingStyle;
 }
 
 - (void)setSmartInsertDeleteEnabled:(BOOL)flag
diff --git a/WebKit/WebView.subproj/WebViewPrivate.h b/WebKit/WebView.subproj/WebViewPrivate.h
index ad49868..98ab979 100644
--- a/WebKit/WebView.subproj/WebViewPrivate.h
+++ b/WebKit/WebView.subproj/WebViewPrivate.h
@@ -6,6 +6,7 @@
 #import <WebKit/WebView.h>
 #import <WebKit/WebFramePrivate.h>
 
+ at class DOMCSSStyleDeclaration;
 @class NSError;
 @class WebBackForwardList;
 @class WebFrame;
@@ -99,6 +100,8 @@ extern NSString *_WebMainFrameURLKey;
     NSString *mediaStyle;
     
     NSView <WebDocumentDragging> *draggingDocumentView;
+    
+    DOMCSSStyleDeclaration *typingStyle;
 }
 @end
 

-- 
WebKit Debian packaging



More information about the Pkg-webkit-commits mailing list