[Pkg-xen-devel] xen backports, sarge dom0 problem

Geoff Crompton geoff.crompton at strategicdata.com.au
Thu Aug 10 04:26:03 UTC 2006


I've tried to get my sarge desktop booting under the xen hypervisor, and
have been having some problems. I've asked about it on the xen-users
mailing lists, the #xen irc channel with oftc, and on the sage-au
mailing lists, but not had any answers at all.

I can boot into the system, but the boot process seems to freeze during
the /etc/rc2.d/S* scripts. It used to freeze while executing
/etc/rc2.d/S20xfs. I worked around that by uninstalling xfs. Now it
freezes while executing /etc/rc2.d/S89atd. That is alot closer to the
end of the startup scripts, so it is tempting to disable atd somehow, to
get it to see if it will boot. But I can't help thinking there is some
underlying problem here, which disabling atd won't solve.

When it does stall, ctrl-c doesn't kill the script, but
ctrl-alt-del does initiate init shutting to runlevel 6. Unfortunately it
then stalls while executing /etc/rc6.d/K20dbus-1.

I've considered it might be a memory limitation, and I've set
dom0_mem=406000 in the /boot/grub/menu.lst for the xen instance. This
didn't make any difference.

The same sarge system boots fine with the plain 2.6.16-2 kernel from

Have you got any tips, or pointers on what I might be doing wrong?

Here is my grub config:
title Xen 3.0 / XenLinux 2.6-686
kernel /boot/xen-3.0-i386.gz dom0_mem=406000
module /boot/vmlinuz-2.6.16-2-xen-686 root=/dev/sda1 ro init=/bin/bash
module /boot/initrd.img-2.6.16-2-xen-686

Here are the settings I've changed in /etc/xen/xend-config.sxp:
(network-script network-bridge)
#(network-script network-dummy)
(vif-script vif-bridge)
(dom0-min-mem 320)

Geoff Crompton
Debian System Administrator
Strategic Data
+61 3 9340 9000

More information about the Pkg-xen-devel mailing list