[Pkg-xen-devel] Bug#376494: xen-utils-3.0: Bashisms in /etc/xen/scripts/* make Xen unable to run domUs

Roberto Suarez Soto turgon at debian.org
Mon Jul 3 10:28:42 UTC 2006

Package: xen-utils-3.0
Version: 3.0.2+hg9681-0bpo1
Severity: important

	Disclaimer: I'm using the packages from www.backports.org here
(in the box where the problem manifested), but I've seen that it happens
too with the packages straight from sid.

	When I installed the packages for Xen and created a domU
("chen.cfg"), it couldn't be brougth up. The error that was displayed

~# xm create -c chen.cfg
Using config file "/etc/xen/chen.cfg".
Error: Device 0 (vif) could not be connected. Hotplug scripts not working.

	Checking the logs, /var/log/xen-hotplug.log was full of lines
like this:

trap: 53: ERR: bad trap

	I am using dash as /bin/sh, and this is the problem. I've not
checked in detail, but it seems that there are bashisms in the scripts
at /etc/xen/scripts that cause this failure. Changing /bin/sh to
/bin/bash fixes the problem.

	The solution would be changing /bin/sh to /bin/bash in the
scripts, or at least warning the user that /bin/sh needs to be /bin/bash
in order for the scripts to work.

-- System Information:
Debian Release: 3.1
Architecture: i386 (i686)
Kernel: Linux 2.6.16-1-xen-686
Locale: LANG=es_ES, LC_CTYPE=es_ES (charmap=ISO-8859-1) (ignored: LC_ALL set to es_ES)

Versions of packages xen-utils-3.0 depends on:
ii  e2fslibs              1.37-2sarge1       ext2 filesystem libraries
ii  iproute               20041019-3         Professional tools to control the 
ii  libc6                 2.3.2.ds1-22sarge3 GNU C Library: Shared libraries an
ii  libncurses5           5.4-4              Shared libraries for terminal hand
ii  python                2.3.5-2            An interactive high-level object-o
ii  udev                  0.093-0bpo1        /dev/ and hotplug management daemo
ii  xen-hypervisor-3.0-i3 3.0.2+hg9681-0bpo1 The Xen Hypervisor for i386
ii  zlib1g                1:1.2.2-4.sarge.2  compression library - runtime

-- no debconf information

More information about the Pkg-xen-devel mailing list