[Pkg-xen-devel] Xen (dom0) Kernels in Lenny

Henning Sprang henning_sprang at gmx.de
Mon Feb 4 11:37:30 UTC 2008

Freeze is coming closer, and it starts more and more to look like there
will be no (complete, especially lacking dom0 Kernel patches) Xen
support in lenny if nothing changes, like:

2) Some people come together and try to work out the needed patches for
the newest Kernels and make them available in Debian. (I don't know
what's the newest available patchset, would be interesting to check what
the other doistributions do and have...)

1) The Kernel team admits and exception from the rule of "only one
single kernel version in Debian". 
-> Making this exception could probably made easier by some people
comitting to help support such an (hypothetical) additional version.

As I am not a kernel hacker myself, so I am not sure which is harder in
terms of work to be done to develop and maintain the stuff - 2) is most
likely harder from a communication/organizational point of view, and
from the work to persuade the Release Managers to let such an additional
Kernel package in. And 1) is the most futureproof thing to do, for sure.

What I know is, it would be a pity and a loss for many users, and for
the reputation of Debian not to ship Xen with Lenny. And I want to do
everything I can to prevent that.

So, what can be done to get this sorted - any ideas, and opinions what
would be needed to do, and where we could get started?


More information about the Pkg-xen-devel mailing list