[Pkg-xen-devel] Bug#507186: xen-utils-3.2-1 doesn't package the xen python library correctly

Thomas Goirand thomas at goirand.fr
Fri Nov 28 22:57:34 UTC 2008

Package: xen-utils-3.2-1
Version: 3.2.1-2
Severity: important

Once installed, the python library of Xen are not in the python search path.
Concequently, it's impossible to import anything from the xen-utils in another
application. The only way to fix it is to do:

cd /usr/lib/python2.5/site-packages
ln -s /usr/lib/xen-3.2-1/lib/python/xen xen

xen-utils-3.2-1 should in fact use the folder /usr/lib/python2.5/site-packages,
and not /usr/lib/xen-3.2.1. By the way, there is no reason why somebody would
want to have 2 version of xen-utils installed at the same time, on a single
computer, IMHO (unless to do some tests, which is not a reason that apply to a
distribution like Debian).

One of the solution would be to simply send the xen python lib directly in the
site-packages of python 2.5, or include a symlink as I described above.

Another way would be to add a .pth file in the xen-utils-3.2.1 package, so it
works as described here:

Anyway what is the choice of the pkg-xen-devel team, something has to be done
to fix the current situation, because it's breaking other packages that are
using Xen and its python files.

-- System Information:
Debian Release: lenny/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux (SMP w/2 CPU cores; PREEMPT)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages xen-utils-3.2-1 depends on:
ii  e2fslibs               1.41.3-1          ext2 filesystem libraries
ii  iproute                20080725-2        networking and traffic control too
ii  libc6                  2.7-16            GNU C Library: Shared libraries
ii  libgcrypt11            1.4.1-1           LGPL Crypto library - runtime libr
ii  libgnutls26            2.4.2-3           the GNU TLS library - runtime libr
ii  libncurses5            5.6+20080830-1    shared libraries for terminal hand
ii  libsdl1.2debian        1.2.13-2          Simple DirectMedia Layer
ii  libxenstore3.0         3.2.1-2           Xenstore communications library fo
ii  python                 2.5.2-3           An interactive high-level object-o
ii  python-central         0.6.8             register and build utility for Pyt
ii  udev                   0.125-7           /dev/ and hotplug management daemo
ii  xen-utils-common       3.2.0-2           XEN administrative tools - common 
ii  zlib1g                 1: compression library - runtime

Versions of packages xen-utils-3.2-1 recommends:
ii  bridge-utils                  1.4-5      Utilities for configuring the Linu
ii  xen-hypervisor-3.2-1-amd64 [x 3.2.1-2    The Xen Hypervisor on AMD64

Versions of packages xen-utils-3.2-1 suggests:
pn  xen-docs-3.2                  <none>     (no description available)

-- no debconf information

More information about the Pkg-xen-devel mailing list