[Pkg-xen-devel] xen on lenny amd64

spmatich at australiaonline.net.au spmatich at australiaonline.net.au
Mon Sep 8 02:43:02 UTC 2008

Hello list
I have run across a problem installing Xen on lenny beta2 amd64 that  
other debian admins might appreciate knowing about.

I installed debian on a DL145-G2 using the lenny beta2 amd64 DVDs. I  
managed to get a  dom0 working without too much trouble using the  
2.6.18-6-xen-amd64 kernel.

So I set up a raid1 device, md1, with the intention of using it for  
the domU root. I created an ext3 file system and copied the lenny root  
to the domU fs. No problems so far.

Then I found that the domU would not boot past the initramfs stage  
because init wouldnt run. I see /sbin/init no such file or directory  
and a kernel panic.

I tried everything I could think of trying to find out why init  
wouldnt start, different root devs (hd,sd,xvd) and different console  
devs (tty1,xvc0). The root file system mounted OK if I stopped the  
boot and had a look at the initramfs prompt. I tried different  
debugging options including building an initrd image with strace built  
in so I could see the progress loading run-init. I tried to boot  
without initial ramdisk.

Several hours later I was thinking maybe there is an issue with my  
hardware. So I did away lenny beta2 + 2.6.18-6-xen-amd64 dom0 and  
tried full etch r3 i386 for dom0. Recreated file systems etc.. I could  
get a domU to boot.

I dimly recalled seeing something when I intalled lenny beta2 that the  
default inode size had changed. But the file system had mounted OK so  
that couldnt be a problem could it? The default ext3 inode size is 256  
bytes in lenny beta 2, and in etch r3 it is 128 bytes.

Then I created a 128 byte inode root file system from the lenny beta2  
+ 2.6.18-6-xen-amd64 dom0 and the domU booted successfully.

I cant see anything documented for this feature/bug anywhere so I  
thought the debian xen list would benefit knowing. I dont know who  
maintains it, but others might save some time if there is a mention of  
this known problem in the debian Xen wiki for Lenny. That is make sure  
to use a 128byte inode file system when creating the domU.

I would not have thought init was sensitive to file system inode size,  
but apparently it is.

Stephen Matich

More information about the Pkg-xen-devel mailing list