[Pkg-xen-devel] Bug#550622: Bug#550622: xen-utils-3.4: NIC 82574L not working

samuix at gmx.de samuix at gmx.de
Mon Oct 12 09:08:43 UTC 2009

Hello Thomas,
Thanks for your answer.

The kernel version is the original version 2.6.26-2-xen-686
cat /pro/version
Linux version 2.6.26-2-xen-686 (Debian 2.6.26-19) 19.August 2009

The NICs are working with Linux Version 2.6.26-2-xen-686 AND
XEN-UTILS-3.2-1, after installation of the newer XEN-UTILS-3.4 the NICS does
not work any longer.

-------- Original-Nachricht --------
> Datum: Mon, 12 Oct 2009 13:52:32 +0800
> Von: Thomas Goirand <thomas at goirand.fr>
> An: samuix at gmx.de, 550622 at bugs.debian.org
> Betreff: Re: [Pkg-xen-devel] Bug#550622: xen-utils-3.4: NIC 82574L not working

> > After installation of linux 2.6.26-2-xen-686 and xen-utils-3.4 the 2
> onboard 
> > NICs 82574L (driver e1000e) are not working.
> > ping results always in unreachable hostname
> > ethtool seems fine for the eth's
> > mii-tool has no transceiver for the eth's
> > ip link show shows an UNKNOWN state for the eth's
> > 
> > With linux 2.6.26-2-xen-686 and xen-utils-3.2-1 the onboard NICs are
> working
> > fine. ping works and mii-tool has transceiver and ip link show shows UP
> as
> > state.
> Exactly what kernel version do you run? If you didn't know, there is
> support for this card starting at kernel 2.6.26-18, thanks to a patch
> that I have tested and pushed to the kernel team. If this is a
> self-compiled kernel, check that it includes
> 0001-e1000e-test-for-unusable-MSI-support.patch and
> 0002-e1000e-add-support-for-82574l.patch otherwise this report is not
> valid, as the issue is not related.
> Thomas

GRATIS für alle GMX-Mitglieder: Die maxdome Movie-FLAT!
Jetzt freischalten unter http://portal.gmx.net/de/go/maxdome01

More information about the Pkg-xen-devel mailing list