[Pkg-xfce-devel] Bug#358249: xfce4-weather-plugin crashes xfce4-panel with glib 2.10

Yves-Alexis Perez corsac at corsac.net
Tue Mar 21 23:12:53 UTC 2006

Package: xfce4-weather-plugin
Version: 0.4.9-3
Severity: normal

After the 2.10 glib upgrade, a xfce4-panel using xfce4-weather-plugin 
will crash with something like:

*** glibc detected *** free(): invalid pointer: 0x10507c80 ***

It's due to the new slice allocator in glib.
You can see: 

A work around is to launch: G_SLICE=always-malloc xfce4-panel

until we fix xfce4-weather-plugin.

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (500, 'stable'), (1, 'experimental')
Architecture: powerpc (ppc)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.16-rc4
Locale: LANG=en_IE at euro, LC_CTYPE=en_IE at euro (charmap=ISO-8859-15)

Versions of packages xfce4-weather-plugin depends on:
ii  libatk1.0-0              1.10.3-1        The ATK accessibility toolkit
ii  libc6                    2.3.6-4         GNU C Library: Shared libraries an
ii  libglib2.0-0             2.10.1-2        The GLib library of C routines
ii  libgtk2.0-0              2.8.13-1        The GTK+ graphical user interface 
ii  libpango1.0-0            1.12.0-2        Layout and rendering of internatio
ii  libxfce4util-1        Utility functions library for Xfce
ii  libxfcegui4-3            4.2.3-1         Basic GUI C functions for Xfce4
ii  libxml2                  2.6.23.dfsg.2-3 GNOME XML library
ii  xfce4-panel              4.2.3-1         The Xfce4 desktop environment pane
ii  zlib1g                   1:1.2.3-11      compression library - runtime

xfce4-weather-plugin recommends no packages.

-- no debconf information

More information about the Pkg-xfce-devel mailing list