[Pkg-xfce-devel] Bug#443874: xfce4-terminal: screen corruption on scroll

Meelis Roos mroos at linux.ee
Mon Sep 24 18:58:27 UTC 2007

Subject: xfce4-terminal: screen corruption on scroll
Package: xfce4-terminal
Version: 0.2.6-4
Severity: normal

*** Please type your report below this line ***

Latest xfc4-terminal has gained a small visual problem - using rtin inside
screen inside ssh inside xfce-terminal results in scrolling artifacts.
rtin is configured to use black text with green background on subject lines and 
other status messages. On scrolling, boxes of green background are scrolled up
and not cleared. 

Pressing ^L inside rtin makes the screen OK again. No UTF-8 locales anywhere 
in case this is important. The same screen+rtin works fine using Konsole and
worked fine using xfce-terminal from around the end of July.

-- System Information:
Debian Release: lenny/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)

Kernel: Linux 2.6.23-rc7
Locale: LANG=et_EE.ISO-8859-15, LC_CTYPE=et_EE.ISO-8859-15 (charmap=ISO-8859-15)
Shell: /bin/sh linked to /bin/bash

Versions of packages xfce4-terminal depends on:
ii  libatk1.0-0                   1.20.0-1   The ATK accessibility toolkit
ii  libc6                         2.6.1-5    GNU C Library: Shared libraries
ii  libdbus-1-3                   1.1.1-3    simple interprocess messaging syst
ii  libdbus-glib-1-2              0.74-1     simple interprocess messaging syst
ii  libexo-0.3-0                  0.3.2-5    Library with extensions for Xfce
ii  libglib2.0-0                  2.14.1-3   The GLib library of C routines
ii  libgtk2.0-0                   2.12.0-2   The GTK+ graphical user interface 
ii  libstartup-notification0      0.9-1      library for program launch feedbac
ii  libvte9                       1:0.16.9-1 Terminal emulator widget for GTK+ 
ii  libx11-6                      2:1.0.3-7  X11 client-side library
ii  libxfce4util4                 4.4.1-1    Utility functions library for Xfce

Versions of packages xfce4-terminal recommends:
ii  dbus                          1.1.1-3    simple interprocess messaging syst

-- no debconf information

More information about the Pkg-xfce-devel mailing list