[pkg-xmule] Bug#316510: xmule crashes with assertion error

Grahame Grahame <grahame@regress.homelinux.org>, 316510@bugs.debian.org
Fri, 01 Jul 2005 14:15:37 +0100

Package: xmule
Version: 1.10.0b-1
Severity: important

When I start xmule it trys to connect to a server and, after failing to connect
to a few, crashes.
Running xmule from a console gives the following error upon crashing:

xmule: pthread_mutex_lock.c:78: __pthread_mutex_lock: Assertion `mutex->__data.__owner == 0' failed.

Looking about on google seems to suggest some kind of LDAP issue but being
ignorant of LDAP I don't know how.

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux
Locale: LANG=en_GB, LC_CTYPE=en_GB (charmap=ISO-8859-1)

Versions of packages xmule depends on:
ii  libc6                    2.3.2.ds1-22    GNU C Library: Shared libraries an
ii  libcrypto++5.2           5.2.1a-1        Crypto++ library
ii  libgcc1                  1:4.0.0-9       GCC support library
ii  libglib1.2               1.2.10-10       The GLib library of C routines
ii  libgtk1.2                1.2.10-17       The GIMP Toolkit set of widgets fo
ii  libstdc++5               1:3.3.6-7       The GNU Standard C++ Library v3
ii  libwxgtk2.4             wxWindows Cross-platform C++ GUI t
ii  libwxgtk2.4-contrib         wxWindows Cross-platform C++ GUI t
ii  libx11-6                 4.3.0.dfsg.1-14 X Window System protocol client li
ii  libxext6                 4.3.0.dfsg.1-14 X Window System miscellaneous exte
ii  libxi6                   4.3.0.dfsg.1-14 X Window System Input extension li
ii  wget                     1.10-2          retrieves files from the web
ii  xlibs                    4.3.0.dfsg.1-14 X Keyboard Extension (XKB) configu
ii  zlib1g                   1:1.2.2-4       compression library - runtime

xmule recommends no packages.

-- no debconf information