[Python-apps-team] Bug#606993: subdownloader: always fail to download selected subs

florian fgruel at hotmail.com
Mon Dec 13 19:17:02 UTC 2010

Package: subdownloader
Version: 2.0.14-1
Severity: grave
Justification: renders package unusable

When launched from commandline, this message appears for all selected subtitle

Traceback (most recent call last):
  File "/usr/share/subdownloader/gui/main.py", line 1043, in onButtonDownload
    destinationPath = self.getDownloadPath(sub.getVideo(), sub)
  File "/usr/share/subdownloader/gui/main.py", line 1012, in getDownloadPath
    downloadFullPath = os.path.join(folderPath, subFileName).decode('utf8')
  File "/usr/lib/python2.6/encodings/utf_8.py", line 16, in decode
    return codecs.utf_8_decode(input, errors, True)
UnicodeEncodeError: 'ascii' codec can't encode character u'\xe9' in position 13: ordinal not in range(128)

-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-5-amd64 (SMP w/4 CPU cores)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages subdownloader depends on:
ii  python                  2.6.6-3+squeeze2 interactive high-level object-orie
ii  python-crypto           2.1.0-2          cryptographic algorithms and proto
ii  python-kaa-metadata     0.7.7-2+b1       Media Metadata for Python
ii  python-support          1.0.10           automated rebuilding support for P

Versions of packages subdownloader recommends:
ii  python-qt4                    4.7.3-1+b1 Python bindings for Qt4

subdownloader suggests no packages.

-- no debconf information

More information about the Python-apps-team mailing list