[Python-apps-team] Getting RabbitVCS 0.15 into Ubuntu 12.04 repos

Jason Heeris jason.heeris at gmail.com
Mon Mar 19 03:01:04 UTC 2012

On 19 March 2012 05:42, Arthur de Jong <adejong at debian.org> wrote:

> I've added a conflicts/replaces to ensure upgrades happen correctly. I
> don't think there is any distribution that ships both nautilus 2 and
> nautilus 3 so that shouldn't be much of a problem.

The problem I'm expecting is this: an Ubuntu user who has the PPA installed
for, say, 12.04 will find that when *we* release a new version and publish
in our PPA, they can't simply upgrade "rabbitvcs-nautilus". It won't be
obvious though, and they'll probably experience major problems when they
try to upgrade Ubuntu's "rabbitvcs-nautilus", which contains the nautilus 3
extension, to our "rabbitvcs-nautilus", a package which actually contains
the extension for nautilus 2.

If you're willing to fix the issues you can probably upload the package
> to the DPMT repository

Um, no thanks :) Someone else can deal with getting packages into Debian
now. If I fix the issues I'll notify whoever's packaging rabbitvcs for

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/python-apps-team/attachments/20120319/c63a1cc6/attachment.html>

More information about the Python-apps-team mailing list