[Python-modules-team] Bug#373201: python-markdown: FTBFS: Missing Build-Depends on 'python-dev'

Andreas Jochens aj at andaco.de
Tue Jun 13 14:46:10 UTC 2006

Package: python-markdown
Version: 1.4-1
Severity: serious
Tags: patch

When building 'python-markdown' in a clean 'unstable' chroot,
I get the following error:

cd . && python setup.py build --build-base="/python-markdown-1.4/./build"
running build
running build_py
cd . && /usr/bin/python setup.py install --root=/python-markdown-1.4/debian/python-markdown/ --no-compile -O0 --install-lib usr/share/python-support/markdown 
running install
error: invalid Python installation: unable to open /usr/lib/python2.3/config/Makefile (No such file or directory)
make: *** [common-install-impl] Error 1

Please add the missing Build-Depends on 'python-dev' to debian/control.

Andreas Jochens

diff -urN ../tmp-orig/python-markdown-1.4/debian/control ./debian/control
--- ../tmp-orig/python-markdown-1.4/debian/control	2006-06-13 12:40:51.000000000 +0000
+++ ./debian/control	2006-06-13 12:40:46.000000000 +0000
@@ -3,7 +3,7 @@
 Priority: optional
 Maintainer: Debian Python Modules Team <python-modules-team at lists.alioth.debian.org>
 Uploaders: Fredrik Steen <stone at debian.org>
-Build-Depends: cdbs, debhelper (>= 4.1.0), python (>=2.3)
+Build-Depends: cdbs, debhelper (>= 4.1.0), python-dev
 Standards-Version: 3.6.2
 Package: python-markdown

More information about the Python-modules-team mailing list