[Python-modules-team] Bug#443105: Bug#443105: libapache2-mod-wsgi: Apache dependencies

Bernd Zeimetz bernd at bzed.de
Tue Sep 18 21:11:45 UTC 2007


> I just tried to install libapache2-mod-wsgi on my machine.  Previous to
> this I had apache2-mpm-prefork and libapache2-mod-php4 installed.
> Since libapache2-mod-wsgi Recommends apache2-mpm-worker or apache2-mpm-event,
> aptitude tried to install apache2-mpm-worker, which resulted in
> libapache2-mod-php4 being broken (since it only works with prefork).
> Maybe libapache2-mod-wsgi should also Depend / Recommend on
> apache-mpm-prefork, or change the Recommends to Suggests?

I've moved the worker suggestion to Suggests in 1.0-2. If you want to
use mod-wsgi or mod-python together with php please note



P.S. My suggestion is to get rid of php ;)

Bernd Zeimetz
<bernd at bzed.de>                         <http://bzed.de/>

More information about the Python-modules-team mailing list