[Python-modules-team] Bug#460413: python-django-registration: Cannot import ugettext_lazy

Raphael Hertzog hertzog at debian.org
Sat Jan 12 15:26:27 UTC 2008

On Sat, 12 Jan 2008, Vincent Bernat wrote:
> After installing python-django-registration and setting up on a fresh
> Django project following instructions in overview.txt.gz, I get this
> error:
> Error: Couldn't install apps, because there were errors in one or more
> models:
> registration: cannot import name ugettext_lazy
> I am using python-django from unstable. The dependency of
> python-django-registration asks for an SVN version but it seems that
> 0.96.1 of Django does not include the necessary changes. In this case,
> the dependency is incorrect. It works fine with 0.97~svn from
> experimental.

Yes, the dependency was no more strict enough. I didn't expect a 0.96.1
release when I choose the versioning. The package is in experimental
precisely because it requires python-django from experimental...

Anyway, I uploaded a fixed package (and a new upstream release!).

Raphaël Hertzog

Le best-seller français mis à jour pour Debian Etch :

More information about the Python-modules-team mailing list