[Python-modules-team] Bug#503385: Bug#503385: /usr/lib/python2.5/site-packages/pytz/__init__.py:29: UserWarning:

Sandro Tosi matrixhasu at gmail.com
Sun Nov 2 13:54:56 UTC 2008

Hi Chris,

On Fri, Oct 31, 2008 at 13:44, Chris Walker
<chrisw at chiark.greenend.org.uk> wrote:
> "Sandro Tosi" <morph at debian.org> writes:
>> Hello Christopher,
>> On Sat, Oct 25, 2008 at 14:19, Christopher J. Walker
>> <chrisw at chiark.greenend.org.uk> wrote:
>> ...
>> > Version: 0.98.3-4
>> ...
>> > chrisw at Daedalus:~$ ipython -pylab
>> > /usr/lib/python2.5/site-packages/pytz/__init__.py:29: UserWarning:
>> > Module dateutil was already imported from
>> > /var/lib/python-support/python2.5/dateutil/__init__.py, but
>> > /var/lib/python-support/python2.5 is being added to sys.path
>> >  from pkg_resources import resource_stream
>> ...
>> > -- System Information:
>> > Debian Release: lenny/sid
>> >  APT prefers testing
>> >  APT policy: (500, 'testing')
>> You reported a bug against the sid version, while reportbug identifies
>> testing as your distribution, and none of the files in the traceback
>> is related to matplotlib: is it possible that the mis-behavior is due
>> to this mix?
> Not sure. I installed the unstable version of matplotlib because the
> testing-proposed updates version hadn't reached testing (and still
> hasn't AFAICT).

yeah, it's a shame, but we are suffering of some tech issue we (mainly
Kumar) are trying to solve, and will be for Lenny release.

>> Is this bug replicatable with the version in lenny
>> (testing-proposed-update), 0.98.1-1+lenny3?
> Yes it is. I've now downgraded to 0.98.1-1+lenny3

That's confirm my supposition that something weird is happening on
your system: on a clean lenny chroot, "ipyhton --pylab" works fine
(tested 5 mins ago).

>> Since yesterday I created
>> a lenny chroot, installed python-matplotlib, and run "ipython --pylab"
>> without any of the warning you're receiving, I can speculate it's
>> something "weird" on your machine, and not in the package.
> That's possible.
> The warning occurs with ipython -pylab and not ipython on its own -
> which is why I reported it against matplotlib - but you are right the
> warning is not coming directly from matplotlib.
> I have python-tz Version: 2008c-2 and python-dateutil Version: 1.4-1
> installed (both are depended upon by matplotlib) - I wonder if it is a
> bug in one of them.

I'm more convinced the problem is in your machine, and not in the mpl
package, but I'd like to hear even from pytz and dateutil maints what
they think about.


Sandro Tosi (aka morph, Morpheus, matrixhasu)
My website: http://matrixhasu.altervista.org/
Me at Debian: http://wiki.debian.org/SandroTosi

More information about the Python-modules-team mailing list