[Python-modules-team] Bug#528345: python-zsi: Error on import ('DefaultHandlerChain' is not defined)

Karl Bartel karlb at gmx.net
Tue May 12 10:11:58 UTC 2009

Package: python-zsi
Version: 2.1~a1-2
Severity: important

I am unable to import ZSI.twisted.WSresource. Tested with python2.4 and 2.5. As there is not much to do wrong on import, I assume this is a bug in the package.

Any information on this will be appreciated.


Python 2.5.2 (r252:60911, Jan  4 2009, 17:40:26) 
[GCC 4.3.2] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import ZSI.twisted.WSresource
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/var/lib/python-support/python2.5/ZSI/twisted/WSresource.py", line 256, in <module>
    class WSAddressHandlerChainFactory:
  File "/var/lib/python-support/python2.5/ZSI/twisted/WSresource.py", line 257, in WSAddressHandlerChainFactory
    protocol = DefaultHandlerChain
NameError: name 'DefaultHandlerChain' is not defined

-- System Information:
Debian Release: 5.0.1
  APT prefers proposed-updates
  APT policy: (500, 'proposed-updates'), (500, 'stable')
Architecture: i386 (i686)

Kernel: Linux 2.6.26-2-686 (SMP w/2 CPU cores)
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)
Shell: /bin/sh linked to /bin/bash

Versions of packages python-zsi depends on:
ii  python                        2.5.2-3    An interactive high-level object-o
ii  python-support                0.8.4      automated rebuilding support for P
ii  python-xml                    0.8.4-10.1 XML tools for Python

python-zsi recommends no packages.

python-zsi suggests no packages.

-- no debconf information

More information about the Python-modules-team mailing list