[Python-modules-team] Bug#525425: python-opengl: Similar error in Python interactive mode

Michael Johnson redbeard at mdjohnson.us
Thu Nov 26 08:23:21 UTC 2009

Package: python-opengl
Version: 3.0.0~c1-1
Severity: normal

When in Python interactive mode, I get the following

>>> help()


help> modules

Please wait a moment while I gather a list of all available modules...

/usr/lib/python2.5/site-packages/twisted/words/im/__init__.py:8: UserWarning: twisted.im will be undergoing a rewrite at some point in the future.
  warnings.warn("twisted.im will be undergoing a rewrite at some point in the future.")
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python2.5/site.py", line 342, in __call__
    return pydoc.help(*args, **kwds)
  File "/usr/lib/python2.5/pydoc.py", line 1650, in __call__
  File "/usr/lib/python2.5/pydoc.py", line 1668, in interact
  File "/usr/lib/python2.5/pydoc.py", line 1684, in help
    elif request == 'modules': self.listmodules()
  File "/usr/lib/python2.5/pydoc.py", line 1805, in listmodules
  File "/usr/lib/python2.5/pydoc.py", line 1856, in run
    for importer, modname, ispkg in pkgutil.walk_packages():
  File "/usr/lib/python2.5/pkgutil.py", line 125, in walk_packages
    for item in walk_packages(path, name+'.', onerror):
  File "/usr/lib/python2.5/pkgutil.py", line 110, in walk_packages
  File "/usr/lib/pymodules/python2.5/OpenGL/Tk/__init__.py", line 87, in <module>
    _default_root.tk.call('package', 'require', 'Togl')
_tkinter.TclError: can't find package Togl

After doing a search I saw that mgltools-opengltk provided
/usr/lib/python2.5/site-packages/opengltk/OpenGL/Tk/Togl/togl.so. Installing that
didn't help and nothing else appears to be close.

Removing python-opengl fixes the problem. But that doesn't seem to be a solution.

Also, could possibly #527342 take care of it?


-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (1, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 2.6.30-2-686 (SMP w/1 CPU core)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages python-opengl depends on:
ii  freeglut3                     2.4.0-8    OpenGL Utility Toolkit
ii  libgl1-mesa-glx [libgl1]      7.6-1      A free implementation of the OpenG
ii  libglu1-mesa [libglu1]        7.6-1      The OpenGL utility library (GLU)
ii  python [python-ctypes]        2.5.4-2    An interactive high-level object-o
ii  python-ctypes                 1.0.2-6    Python package to create and manip
ii  python-support                1.0.4      automated rebuilding support for P

python-opengl recommends no packages.

Versions of packages python-opengl suggests:
ii  libgle3                       3.1.0-7    OpenGL tubing and extrusion librar
ii  python-numpy                  1:1.3.0-3  Numerical Python adds a fast array
ii  python-tk                     2.5.2-1.1  Tkinter - Writing Tk applications 

-- no debconf information

More information about the Python-modules-team mailing list