[Python-modules-team] Bug#589172: please provide 2 packages: pyro and pyro4

Alexandre Fayolle afayolle at debian.org
Thu Aug 12 08:55:56 UTC 2010

As Sylvain said, pyro4 breaks the abi and therefore this upgrade breaks any 
application deployed on the system depending on pyro 3.x. 

The best move imo would be to keep pyro4 in experimental, since most users are 
using the official stable release (3.x branch), and reverting to pyro3 in 

I suggest providing 2 packages pyro and pyro4, which could at first conflict 
with each other. I think upstream should be contacted, and asked to change the 
namespace of pyro 4.x to pyro4 in order to ease parallel installation of both 

In any case, please do not release squeeze with pyro 4.x as "pyro". This will 
be very painful. We really want pyro 3.9 in squeeze, as 4.x will break 
external applications. 

I'll be happy to help on this matter once 
Alexandre Fayolle                              LOGILAB, Paris (France)
Formations Python, CubicWeb, Debian :  http://www.logilab.fr/formations
Développement logiciel sur mesure :      http://www.logilab.fr/services
Informatique scientifique:               http://www.logilab.fr/science

More information about the Python-modules-team mailing list