[Python-modules-team] Bug#562449: celementtree: Depends on python2.4 packages

Raphael Hertzog hertzog at debian.org
Wed Jan 13 09:49:40 UTC 2010

forcemerge 562449 564377
reassign 562449 ftp.debian.org
retitle 562449 RM: celementtree -- RoM; only useful with python < 2.5

On Thu, 24 Dec 2009, dktrkranz at debian.org wrote:
> Squeze will release with Python 2.5 and Python 2.6, while Python 2.4
> is scheduled for removal when no packages will depend on it. Recent
> python-defaults disabled support for Python 2.4 already, so it is no
> longer supported version for module and extension building.
> This package is either part of standard library in newer Python, or
> known not to work with Python 2.5 or newer, so it will be removed in
> a very near future.
> If you don't believe this package has to be removed, please follow in
> the bug report, otherwise this will become a RM request together with
> python2.4 package.

It's about time to remove the package since it now fails to build from
source due to the fact that python 2.4 support is disabled already (see

Thus I'm reassigning it to ftp.debian.org.

Raphaël Hertzog

More information about the Python-modules-team mailing list