[Python-modules-team] Bug#574632: Missing dependency on python-markdown

Enrico Zini enrico at debian.org
Fri Mar 19 15:03:07 UTC 2010

Package: python-turbogears2
Version: 2.0.3-1
Severity: normal


in a turbogears2 project:

$ python setup.py --help-commands
Traceback (most recent call last):
  File "setup.py", line 48, in <module>
  File "/usr/lib/python2.5/distutils/core.py", line 137, in setup
    ok = dist.parse_command_line()
  File "/usr/lib/python2.5/site-packages/setuptools/dist.py", line 232, in parse_command_line
    result = _Distribution.parse_command_line(self)
  File "/usr/lib/python2.5/distutils/dist.py", line 455, in parse_command_line
    if self.handle_display_options(option_order):
  File "/usr/lib/python2.5/distutils/dist.py", line 680, in handle_display_options
  File "/usr/lib/python2.5/site-packages/setuptools/dist.py", line 369, in print_commands
    cmdclass = ep.load(False) # don't require extras, we're not running
  File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 1948, in load
    entry = __import__(self.module_name, globals(),globals(), ['__name__'])
  File "/usr/lib/pymodules/python2.5/turbogears/__init__.py", line 8, in <module>
    from turbogears import (controllers, view, database, validators, command,
  File "/usr/lib/pymodules/python2.5/turbogears/widgets/__init__.py", line 1, in <module>
    from turbogears.widgets.base import *
  File "/usr/lib/pymodules/python2.5/turbogears/widgets/base.py", line 5, in <module>
    from turbogears import view, startup, config
  File "/usr/lib/pymodules/python2.5/turbogears/startup.py", line 31, in <module>
  File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 648, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 546, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: Markdown>=2.0.1

It looks like TurboGears depends on Markdown. Why would it do that, it's
beyond me, but then again, I better not get started on the topic of
python dependencies.

Installing python-markdown, python setup.py --help-commands works again.



-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-trunk-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages python-turbogears2 depends on:
ii  python-genshi                 0.5.1-2+b1 Python XML-based template engine
ii  python-pylons                 0.10~b1-1  Python web framework emphasizing f
ii  python-repoze.tm2             1.0a4-2    Zope-like transaction manager via 
ii  python-repoze.what-plugins    20090531-2 authorization framework for Python
ii  python-support          automated rebuilding support for P
ii  python-toscawidgets   Python framework for building reus
ii  python-turbojson              1.2.1-4    Plugin to use JSON templates in Py
ii  python-weberror               0.10.2-1   Python web error handling and exce
ii  python-webflash               0.1a9-3    Portable flash messages for Python

Versions of packages python-turbogears2 recommends:
ii  python-pysqlite2              2.5.5-3+b1 Python interface to SQLite 3
ii  python-tg.devtools            2.0.2-1    developer tools for the TurboGears

Versions of packages python-turbogears2 suggests:
ii  python-elixir                 0.7.1-1    Declarative Mapper for SQLAlchemy

-- no debconf information

More information about the Python-modules-team mailing list