[Python-modules-team] Bug#605365: Bug#605365: pyopenssl: Use dh_python2 instead of dh_pysupport

Daniel Holbach daniel.holbach at ubuntu.com
Mon Nov 29 14:42:55 UTC 2010

On 29.11.2010 15:17, Sandro Tosi wrote:
>>  * Rebuild with Python2.7.
> In Debian we would have scheduled a binNMU and get done with it, so
> there's nothing in the package to be done.

In Ubuntu we don't have binNMUs. We need to do source uploads for rebuilds.

>>  * debian/rules: change dh_pysupport to dh_python2.
>>  * debian/control: Removed python-support from Build-Depends.
> what's the point of this change?

The way I understood
was that the idea was to move away from dh_pysupport in favour of

As pyopenssl needed a rebuild in Ubuntu in order to give us OpenSSL for
2.7 (I needed it for a papyon build), I thought I'd make the change in
the same upload and forward the changes to you.

>> We thought you might be interested in doing the same.
> "we" as in? why not discussing it with us BEFORE apply a useless diff
> diverging from debian?

"we" as in the default piece of text that "submittodebian" provides.

I'm not sure you intended it this way, but your answer comes across as
quite a bit agitated. Please take my word for it that I only had the
best intentions.

As I said: to me it looked like a straight-forward thing to get things
in the Ubuntu archive into a build-able state again. I'm sorry if I
misunderstood things. (I still don't understand what exactly what about
my change was wrong.)

Have a great day,

More information about the Python-modules-team mailing list