[Python-modules-team] Bug#601259: FTBFS if only built with Python >=2.6

Christian Kastner debian at kvr.at
Mon Oct 25 22:30:50 UTC 2010

On 10/25/2010 06:15 PM, Luke Faraone wrote:
> On 10/24/2010 06:40 PM, Jakub Wilk wrote:
>> armel, hppa, mips, powerpc, maybe s390, plus all non-Linux ones. Use
>> something like:
>> $(shell python -c 'import distutils.util as d; print d.get_platform()')
> Okay, I've committed the above. Is this solution acceptable to everyone?

No major objections on my part, I just consider my patch simpler. This
is a module, not an extension, so the build result is identical -- which
is why dh_pysupport grabs only one version. An elaborate construction to
run the tests using the build from the corresponding Python version
appears overly complex to me.

Again, this is just a comment. I'm fine either way as long as it fixes
the bug.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 899 bytes
Desc: OpenPGP digital signature
URL: <http://lists.alioth.debian.org/pipermail/python-modules-team/attachments/20101026/13a457b9/attachment-0001.pgp>

More information about the Python-modules-team mailing list