[Python-modules-team] Bug#647210: python-qt4: uploaded 4.8.6-1 version broke guiqwt

Picca Frédéric-Emmanuel picca at synchrotron-soleil.fr
Mon Oct 31 17:10:01 UTC 2011

Package: python-qt4
Version: 4.8.6-1
Severity: serious

Dear Maintainer,

since the upload of the 4.8.6, I got his error when I try to use

picca at mordor:~/Debian/main/spyder$ guiqwt-tests 
Traceback (most recent call last):
  File "/usr/bin/guiqwt-tests", line 3, in <module>
  File "/usr/lib/python2.7/dist-packages/guiqwt/tests/__init__.py", line 17, in run
  File "/usr/lib/python2.7/dist-packages/guidata/guitest.py", line 157, in run_testlauncher
    win = TestLauncherWindow(package)
  File "/usr/lib/python2.7/dist-packages/guidata/guitest.py", line 126, in __init__
    tests = get_tests(test_package)
  File "/usr/lib/python2.7/dist-packages/guidata/guitest.py", line 34, in get_tests
    _temp = __import__(test_package.__name__, fromlist=[module_name])
  File "/usr/lib/python2.7/dist-packages/guiqwt/tests/computations.py", line 12, in <module>
    from guiqwt.plot import CurveDialog
  File "/usr/lib/python2.7/dist-packages/guiqwt/plot.py", line 119, in <module>
    from guiqwt.baseplot import BasePlot
  File "/usr/lib/python2.7/dist-packages/guiqwt/baseplot.py", line 57, in <module>
    from guiqwt.transitional import (QwtPlot, QwtLinearScaleEngine,
  File "/usr/lib/python2.7/dist-packages/guiqwt/transitional.py", line 19, in <module>
    from PyQt4.Qwt5 import (QwtPlot, QwtSymbol, QwtLinearScaleEngine,
  File "/usr/lib/python2.7/dist-packages/PyQt4/Qwt5/__init__.py", line 32, in <module>
    from Qwt import *
RuntimeError: the PyQt4.QtCore module is version 1 but the PyQt4.Qwt5.Qwt module requires version -1

I put serious as it can maybe break other rdepends of python-qt4.

I am trying to rebuild pyqwt5 to check if it solve the issue.

See you


-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'stable'), (1, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 3.0.0-2-486
Locale: LANG=fr_CA.UTF-8, LC_CTYPE=fr_CA.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages python-qt4 depends on:
ii  libc6                     2.13-21           
ii  libgcc1                   1:4.6.2-3         
ii  libpython2.7              2.7.2-6           
ii  libqt4-declarative        4:4.7.3-8         
ii  libqt4-designer           4:4.7.3-8         
ii  libqt4-help               4:4.7.3-8         
ii  libqt4-network            4:4.7.3-8         
ii  libqt4-script             4:4.7.3-8         
ii  libqt4-scripttools        4:4.7.3-8         
ii  libqt4-svg                4:4.7.3-8         
ii  libqt4-test               4:4.7.3-8         
ii  libqt4-xml                4:4.7.3-8         
ii  libqt4-xmlpatterns        4:4.7.3-8         
ii  libqtassistantclient4     4.6.3-3           
ii  libqtcore4                4:4.7.3-8         
ii  libqtgui4                 4:4.7.3-8         
ii  libqtwebkit4              2.1.0~2011week13-2
ii  libstdc++6                4.6.2-3           
ii  python                    2.7.2-9           
ii  python-sip [sip-api-8.1]  4.13-1            
ii  python2.6                 2.6.7-4           
ii  python2.7                 2.7.2-6           

python-qt4 recommends no packages.

Versions of packages python-qt4 suggests:
pn  python-qt4-dbg  <none>

-- no debconf information

More information about the Python-modules-team mailing list