[sane-devel] XSANE 0.80 compilation problems

Henning Meier-Geinitz henning@meier-geinitz.de
Sun, 4 Nov 2001 12:48:17 +0100


On Sun, Nov 04, 2001 at 12:33:03AM +0100, Johan Bengtsson wrote:
> checking for png_create_info_struct in -lpng... yes
> ****************************************************************
> ERROR: SANE-1.0.0 or newer is needed for compiling xsane
>      - if you installed SANE as rpm make sure you also included
>        sane-devel
> ****************************************************************

The interesting part is some lines above, something like:

| checking for sane-config... no
| checking for SANE - version >= 1.0.0... no
| *** The sane-config script installed by SANE could not be found
| *** If SANE was installed in PREFIX, make sure PREFIX/bin is in
| *** your path, or set the SANE_CONFIG environment variable to the
| *** full path to sane-config.

Further more, there should be more information about what happened in

There was a bug in the configure script of SANE 1.0.5 concerning
libusb. It's also "found" if only usb.h but not libusb.so is present.
This may result in such a problem.

I think, this is a sane-backends problem. Try the latest snapshot from
http://www.mostang.com/sane or wait for SANE 1.0.6 which will be
released during the next days. After compiling sane-backends, do "make
distclean" in xsane-0.80 and start configure again.