[sane-devel] [Fwd: AGFA SnapScan e20]

Felix Hermann felix_hermann@web.de
Sat, 06 Oct 2001 16:35:02 +0200

LOL I found one error: My mother installed the scanner (I mean she 
unpacked and plugged it in) but did not the transport lock =) ... 
However this is fixed, the scanner uploads the firmware correctly as 
before but

hermaf:~ # xscanimage
[sanei_debug] Setting debug level of snapscan to 255.
[snapscan] sane_snapscan_init
[snapscan] add_device(/dev/usbscanner)
[snapscan] add_device: Detected (kind of) an USB device
[snapscan] usb_open(/dev/usbscanner)
[snapscan] mini_inquiry
[snapscan] snapscan_cmd
[snapscan] sanei_usb_cmd(10,0xbfffd524,6,0xbfffd500,0xbfffd4fc (36))
[snapscan] atomic_usb_cmd(10,0xbfffd524,6,0xbfffd500,0xbfffd4fc (36))
[snapscan] usb_cmd(10,0xbfffd524,6,0xbfffd500,0xbfffd4fc (36))
[snapscan] usb_cmd: cmdlen=6, datalen=0
[snapscan] usb_write: writing:  0x12 0x00 0x00 0x00 0x24 0x00
[snapscan] usb_read: reading:  0xf9 0x00 0x00 0x00 0x00 0x00 0x00 0x00
[snapscan] usb_read: reading:  0x06 0x00 0x02 0x02 0x49 0x00 0x00 0x00 
0x41 0x47 ...
[snapscan] usb_read: reading:  0xfb 0x00 0x00 0x00 0x00 0x00 0x00 0x00
[snapscan] add_device: Is vendor "AGFA" model "SNAPSCAN e20" a supported 
[snapscan] add_device: "AGFA SNAPSCAN e20" is not one of AGFA SnapScan 
300, 310, 600 or 1236s, Acer VUEGO 300, 310S, 610S, or 610plus, Acer 
PRISA model 620S
[snapscan] usb_close(10)
[snapscan] sane_snapscan_get_devices (0xbfffe6b8, 0)
[xscanimage] No scanners were identified. If you were expecting something
          different, check that the scanner is plugged in, turned on and
          detected by the find-scanner tool (if appropriate). Please read
          the documentation which came with this software (README, FAQ,
[snapscan] sane_snapscan_exit

There is still that errror that I get =) Without the Firware I get the 
result as before: I/O Error ... but xscanimage starts up without the 
firmware ...


PS: No other locks or so on the scanner ;-) I double-checked it now ...

Oliver Schwartz wrote:

>you should try the latest snapscan backend from 
>http://sourceforge.net/projects/snapscan - currently this is 
>snapscan-20010928.tar.gz. You my also get it directly from 
>please also read the release notes 
>If it still doesn't work please send me a debug log. To do this, run "export 
>SANE_DEBUG_SNAPSCAN=255" in your shell, then execute "xscanimage 2>debug.log" 
>and send me the debug.log file.
>Sane-devel mailing list