[sane-devel] Solaris 'sgen' driver problem was device permission related!

Craig Dewick cdewick@sunshack.org
Mon, 15 Apr 2002 08:54:02 +1000 (EST)

I've got xsane to talk with my scanner finally. The problem was that the
device handle in /dev/scsi/scanner was not owned by the user ID I normally
log in as.

I found this by trying to run 'scanimage' as root, and it worked. 8-) So I
set up some extra lines in my script that runs at boot time to change some
of the device handle owners to the right user-ID, and it's worked!

Now I need to deduce a problem with the scanner itself. During a scan
(preview or a full scan), the scanning element carrier stops about 1/4 of
the way into the scan and while the electronics continue to send data back
the scanning element carrier jitters back and forth as though either it's
being physically impeded or something is wrong with the scanner's
electronics and the stepper motor for it is getting out of phase and
losing it's ability to step properly. The scanner is Microtek
Scanmaker-III, so if anyone has had this problem with their SM-III
scanner, please contact me privately if you know what the solution could

Otherwise, I'm happy to report that the whole SANE package, and xsane,
works fine in Solaris 8 using the 'sgen' driver. At least that appears to
be the case until the problem with the scanner itself is investigated
thoroughly. 8-)



               Craig Dewick. Send email to "cdewick@sunshack.org"
 Point your web client at "www.sunshack.org" or "www.sunshack.net" to access my
 archive of Sun technical information and links to other places. For info about
     Sun Ripened Kernels, go to "www.sunrk.com.au" or "www.sun-surplus.com"