[sane-devel] 1.0.7 can't find Microtek X6EL

K. Holcomb kholcomb@cs.virginia.edu
Fri, 8 Mar 2002 17:17:42 -0500 (EST)

I am running RedHat 7.2, which came originally with sane 1.0.5.  My Microtek
X6EL was not detected by sane-find-scanner even though it shows up in
/proc/scsi/scsi.  In light of the FAQ answer concerning sane 1.0.5 and scanners 
that do not report a vendor string (which it does not do), I just upgraded to 
the sane-backends and sane-frontends RPMS from RedHat's Rawhide, which purport
to be sane version 1.0.7, but no joy -- it still doesn't see the scanner.

cat /proc/scsi/scsi gives
Attached devices: 
Host: scsi0 Channel: 00 Id: 06 Lun: 00
  Vendor:          Model: scanner 636EL    Rev: 1.20
  Type:   Scanner                          ANSI SCSI revision: 02
Host: scsi1 Channel: 00 Id: 00 Lun: 00
  Vendor: IOMEGA   Model: ZIPCD1024INT-A   Rev:  1.1
  Type:   CD-ROM                           ANSI SCSI revision: 02

The IOMEGA is a CD burner and it is actually using the ide-scsi interface.
Those of us with ATAPI CD burners have no choice but to use this module.
The "real" SCSI-relevant modules I have loaded are
aic7xxx               136448   1 
scsi_mod              109396   5  [sg sr_mod ide-scsi aic7xxx sd_mod]

I generated a log file from scanimage but it's not very interesting:
scanimage: no SANE devices found

Is this vendor-string bug still present, or am I doing something wrong?  I have 
corrected the permissions on /dev/sg0 (but it doesn't work even as root).

Sane definitely used to work quite well with this scanner, but I am not sure 
I have tried it since I attached it to a newer computer with the CD burner.

Thanks very much.