[sane-devel] In search of a master

Henning Meier-Geinitz henning@meier-geinitz.de
Thu, 18 Dec 2003 17:53:24 +0100


Hi,

On Wed, Dec 17, 2003 at 07:31:03PM -0500, Jason Anderson wrote:
> Sorry if I'm bothering you people, but I cannot get this code to
> properly compile.  It keeps spitting out error after error.

It would really help if you wrote what you are actually trying to
achieve, which source code you use and what the errors are. And please
stay in the same thread (same subject) all the time you talk about the
same problem. That way it's easier to follow the discussions.

> As some of you know, I have been trying to use the function
> "Sanei_usb_open()",

It's "sanei_usb_open()" (no captial letter).

> but have recieved many errors from header files.

If you include internal SANE header files, you should 

> I have tried to remedy this with including the "sane", "sanei", and
> "sanei_usb" header files.  Now, I am trying to find someone who will
> work with me on this.

> I don't know if one of the header files has the wrong code, so I will
> check to see if they're correct. 

If they were that buggy, they wouldn't work in SANE.

Anyway you are partially right: sanei_usb.h should include a header
that defines size_t.

This compile for me (in the backend directory, file called "hubba.c"):

#include "../include/sane/config.h"
#include <unistd.h>
#include "../include/sane/sanei_usb.h"

int
main ()
{
}

Try "gcc -I. hubba.c". And add some code actually :-)


Does anyone know which standard header file to include for size_t?
Shouldn't that be included in sanei_usb.h evene if a backend includes
it anyway?

Bye,
  Henning