[sane-devel] backend naming conventions/constraints
28 Feb 2003 08:52:15 +0900
Henning Meier-Geinitz <firstname.lastname@example.org> writes:
> On Thu, Feb 27, 2003 at 09:16:35AM +0900, Olaf Meeuwissen wrote:
> > Yup, backends/Makefile.in uses
> > %-s.lo: %-s.c
> > @$(LIBTOOL) $(MCOMP) $(COMPILE) -DSTUBS -DBACKEND_NAME=$* $<
> > %.lo: %.c
> > @$(LIBTOOL) $(MCOMP) $(COMPILE) -DBACKEND_NAME=$* \
> > -DLIBDIR=$(libsanedir) $<
> > So using epson-kowa.c screws things up. However, I only have one
> > backend to build with "Image Scan!" so I could hack around this.
> > Either in Makefile.in or in my source file.
> Yes, but isn't you backend used together with other frontends?
I don't know, probably yes, but how does that interact with the way I
build the epson-kowa backend? Does libsane-dll choke on hyphenated
FYI, "Image Scan!" depends on sane-backends to load its backend (to
the best of my knowledge, I inherited the code and haven't wrapped my
brain around it quite yet) and "borrows" the sane-backends code to get
its custom backend build.
> > BTW, is there any reason the build system is not updated to reflect
> > the improved capabilities of libtool? It pretty much seems to be
> > based on libtool-1.0 or so, while the current version is 1.4.
> Libtool in SANE is 1.4.3. Can you explain the "improved capabilities"
> in more detail? We usually only update libtool if absolutely necessary
> because it requires manual inclusion of our local changes. And I
> hesitate to change anything in backend/Makefile.in if I don't fully
> understand the implications :-)
Understood. I was referring to the Makefile.in rules, which to me
seemed a bit, eh, well, manual. But then again, when was the last
time I wrote a Makefile.in? Since I switched to automake, I guess.
If SANE uses libtool 1.4.3, I'd say you're up-to-date.
> > > Why don't you use "libsane-epson_kowa" or "libsane-epsonkowa"?
> > Apart from esthetics and readability? Guess not, so it boils down to
> > whether I think it's worth the trouble.
> The other backends that use more than one "word" use "_" (e.g.
Time permitting, I'll see what happens with epson-kowa and if that
does not work or otherwise breaks things (including some of the other
frontends) I think I'll use "epkowa" after our domain name.
Olaf Meeuwissen EPSON KOWA Corporation, ECS
GnuPG key: 6BE37D90/AB6B 0D1F 99E7 1BF5 EB97 976A 16C7 F27D 6BE3 7D90
Penguin's lib! -- I hack, therefore I am -- LPIC-2