[sane-devel] FreeBSD and a Epson Perfection 1260

Henning Meier-Geinitz henning@meier-geinitz.de
Thu, 16 Jan 2003 11:25:24 +0100


On Wed, Jan 15, 2003 at 10:01:19PM +0100, Michael Lestinsky wrote:
> I obtained a Epson Perfection 1260 scanner and am trying now to convice my
> FreeBSD (4.7, RELENG_4 from yesterday evening) to support that scanner.
> I'm using the sane-backends-1.0.10-pre1 sources.
> First I tried it via libusb(0.1.7)/ugen driver:

> [sanei_usb] sanei_usb_open: chosing first altsetting (0) without checking
> USB error: could not set alt intf 0/0: Invalid argument
> [sanei_usb] sanei_usb_open: libusb complained: could not set alt intf 0/0:
> Invalid argument

Looks like FreeBSD doesn't like usb_set_altinterface, either. That's
already changed in CVS.

Edit sanei/sanei_usb.c, search for the call to usb_set_altinterface
and comment it out (including the if (result < 0) test after the call).

> After that I patched the product id of the scanner into the uscanner
> driver of FreeBSD and enabled that module. The scanner is recognised by
> the module on load. But it doesn't scan either:
> $ scanimage -L
> [...]
> [sanei_debug] Setting debug level of sanei_usb to 255.
> usb_set_debug: Setting debugging level to 255 (on)
> [sanei_usb] sanei_usb_find_devices: vendor=0x04b8, product=0x011d, attach=0x282206fc
> [sanei_usb] sanei_usb_open: trying to open device `/dev/uscanner'
> [sanei_usb] sanei_usb_open: open of `/dev/uscanner' failed: No such file or directory
> [sanei_usb] sanei_usb_open: trying to open device `/dev/uscanner0'
> [sanei_usb] sanei_usb_open: opened usb device `/dev/uscanner0' (*dn=0)
> [sanei_usb] sanei_usb_get_vendor_product: device 0: Your OS doesn't seem to support detection of vendor+product ids

Well, your OS really doesn't support detection of vendor + product ids :-)

You can give the ids in plustek.conf as far as I know.