[sane-devel] error in linux/videodev.h

Thomas Soumarmon soumarmt@nerim.net
Sun, 8 Jun 2003 10:17:41 +0200



> > Follows the errors :
> >
> > In file included from /usr/include/linux/videodev.h:14,
> >                  from v4l.c:76:
> > /usr/include/linux/videodev2.h:432: parse error before "v4l2_std_id"
> > /usr/include/linux/videodev2.h:432: ISO C forbids data definition with no
> > type or storage class
> Maybe that's the result over our pedantic warning settings. Try with
> "--disable-warnings". Looks like the header file is not ISO
> C-conforming (for whatever version of ISO-C).

I'll try that later and tell you what it changes.

> Where did you get videodev2.h from? Is it from your version of libc
> (which one)? Or is /usr/include/linux a link to
> /usr/src/linux/include/linux and you have installed a 2.5 kernel?

Looking with the rpmdrake tool (Mdk 9.1 installed) it says that videodev2.h
belongs to :
glibc-devel-2.3.1-10mdk or kernel-source-2.4.21-0.13mdk

I am wondering if this is exact or if it belongs to another package I would 
have tried on the machine (they have been numerous).

> We'll have to think about supporting v4l version 2 anyway. There is an
> old v4l2 backend, but nobody yet responded to the question if v4l2 is
> the same as the new version 2 kernel interface.

Have a nice day,