[sane-devel] error in linux/videodev.h

Thomas Soumarmon soumarmt@nerim.net
Mon, 9 Jun 2003 11:45:56 +0200

Hi Henning,

> Kernel version 2.4.21 is not released yet and the pre versions don't
> have that file. Anyway, kernel headers shouldn't be used from
> userspace. So it's probably from glibc. I'm just wondering why it's
> not on my system, I'm using the same version of glibc.
> > I am wondering if this is exact or if it belongs to another package I
> > would have tried on the machine (they have been numerous).
> Shouldn't rpm know which package installed a specific file?

My problem is more the .tar.gz packages I installed and tested, and also the 
different kernels (2.4.19, 2.4.20 to 2.5.?? ). That is why I think it is 
specific to my installation, but I was wondering if anyone else had that 
problem so that it could help me to find the reason and the fix.

I'll probably try to force reinstallation of glibc rpm to fix it.

Your idea was right for the --disable-warnings. It compiles OK with it.