[sane-devel] hp scanjet 6200c flakeyness

Jeremiah Benham jjbenham at chicagoguitar.com
Wed Aug 2 02:58:32 UTC 2006

On Tue, Aug 01, 2006 at 09:18:50PM -0500, Jeremiah Benham wrote:

Here is an error I got from scanimage:
scanimage: hp-option.c:3713: hp_optset_fix_geometry_options: Assertion
`tl_x && tl_y && br_x && br_y' failed

> I just recieved a hand-me-down hp scanjet 6200c. The problem I am having
> is that I can scan about 10 images or so and then the scanner needs to
> be unpluged from usb and pluged back in. The scanner just stops working
> after about 10 scans or so. I reset the power on the
> scanner also when doing this. The errors I get from xsane are these:
> Error during read: Error during device I/O
> Failed to open `(null)': Bad address
> Failed to start scanner: End of file reached
> I am using sane-backends 1.0.18-r2
> xsane 0.991
> libusb 0.1.12
> kernel 2.6.16-gentoo-r9
> cpu amd64 (x86_64)
> distro Gentoo
> usb bus uhci_hcd
> The command line tool scanimage gives me all the same issues that xsane
> does. 
> Let me know what I should do to debug this issue. I know c but have not
> dived into the code yet. Any debugging docs for sane backends. Is this a
> libusb issue? I guess I need to know where to point the finger.
> Jeremiah
> -- 
> sane-devel mailing list: sane-devel at lists.alioth.debian.org
> http://lists.alioth.debian.org/mailman/listinfo/sane-devel
> Unsubscribe: Send mail with subject "unsubscribe your_password"
>              to sane-devel-request at lists.alioth.debian.org

More information about the sane-devel mailing list