[sane-devel] scanimage: sane_start: Out of memory - Umax Astra 600S

Mattias Ellert mattias.ellert at tsl.uu.se
Thu Nov 15 21:14:42 UTC 2007

15 nov 2007 kl. 20.57 skrev m. allan noah:

> On Nov 14, 2007 5:19 PM, Alexander Melhuish <awm106 at ecs.soton.ac.uk>  
> wrote:
>> Hello,
>> I am attempting to make my scanner work. It is a Umax Astra 600S
>> attached via a SCSI-Firewire interface to my MacBook, which is  
>> running
>> Mac OS X 10.5. I'm using the latest version of the TWAIN-SANE
>> packages, which includes sane-backends 1.0.18. I tested this
>> configuration with a demo of SilverFast, which functioned properly.
>> So far, the only way to have a complete response is using the --mode
>> LineArt option - anything else and the scanner and/or interface
>> 'crash'. Even in this mode though, no image is produced.
>> Using SANE_DEBUG_SANEI_SCSI=255 and SANE_DEBUG_UMAX=255, I produced
>> the attached log file. I have tried experimenting a little with the
>> buffer options for sane_umax, but I'm not convinced that the back-end
>> is at fault.
>> Anyone with experience of 'Out of memory' errors or sane_umax, please
>> respond. Any suggestions are welcome to just get basic functionality
>> to start with.
> looks like a threading issue, and the 'eom' errors are just a side
> effect. I dont know anything about threading on OSX- but i bet mr
> ellert does. If he does not respond to this mail, you should email him
> directly.
> allan

Could you add SANE_DEBUG_SANEI_THREAD=255 to the set of debug values?


-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 1438 bytes
Desc: not available
Url : http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20071115/7e01f21c/attachment.bin 

More information about the sane-devel mailing list