[sane-devel] Can't seem to find config files

Jack McGill jmcgill85258 at yahoo.com
Tue Nov 4 22:35:01 UTC 2008

I reread your post and I didn't answer all of your questions.

As far as your question about the sane-find-scanner resulting in two
"found USB scanner (vendor=0x055f [Hewlett-Packard.        ],
product=0x0408 [USB2.0 Scanner            ], chip=SQ113) at
found USB scanner (vendor=0x16d5, product=0x6501) at libusb:004:003
  # Your USB scanner was (probably) detected. It may or may not be
supported by.."

The first product is your scanner. The second product is not a scanner, it is an anydata cdma modem. 
You probably have a usb device for internet access via a cellular phone
company that was connected when you ran sane-find-scanner.

It is confusing that the results say your scanner is an HP, but sometimes the same scanner is relabeled and sold under
several different labels.

As for not being able to find anything in /etc/sane.d, it sounds like your re-installation might not have completed correctly.
In my case using Ubuntu Hardy, I would download the CVS or latest daily build and extract it to my home folder.
Then at the terminal type
$ cd home/jack/sane-backends
$ ./configure
$ make
$ sudo make install

then plug in your scanner and 
$ sane-find-scanner, which should list your scanner.
Then try
$ scanimage -L, which probably won't list your scanner.
then repeat scanimage -L as root or sudo, which probably won't find you scanner.

You then could try the to make the changes to the source code that I talked about in my previous post and redo 
$ ./configure
$ make
$ sudo make install
$ scanimage -L
$ sudo scanimage -L
If your scanner shows up after scanimage -L as root, but not as a regular user, then depending on your distribution,
there are some tweaks that we can do.

If your scanner is listed after scanimage -L, then open xsane from the terminal and try to scan something from the GUI.
$ xsane
Keep your hand on the power cord and be ready to quickly unplug it if you hear any strange noises.

Depending on your results you could then try
$ xsane
then scan something and look at the debug log.

At this point you may need to do a USB snoop under windows. 

If anyone else has anything to add, feel free to correct me. Like I said, I only know enough to be dangerous ;).
Jack McGill 

More information about the sane-devel mailing list