[sane-devel] problems on OS/2

Franz Bakan fbakan at gmx.net
Sat Feb 7 20:06:01 UTC 2009


On Sat, 07 Feb 2009 12:41:41 -0600, Chris Bagwell wrote:

> Can you email me the old patched libtool?  Perhaps I can forward port 
> what ever OS/2 changes to latest libtool for you.
> Can you log the output of each failed run to me?  I'd like to see the 
> filenames that are failing to see if I can find any Makefile issues.
> I've heard this type of failure before for OS/2 but never understood how 
> a second run could resolve it.

I built again and zipped the result.

you can get it here:


The zip-file contains the generated libtool, the main Makefile,
the output from configure and make stdout (.1) and stderr (.2)
and the old os2-specific-libtool, which used to work.

> Can you verify that the frontends/scanimage.exe is a working program 
> after this?

Yes, scanimage.exe is a working program

>  Its good to know that we are generating a good executable 
> and then we can move on to share library issues... From my limited 
> experience, I've always heard the first thing people do is 
> "--disable-shared --enable-static" on OS/2 (no DLL's)... So I suspect 
> your patched libtool was some custom solution that allowed DLL's to be 
> created on OS/2.

Probably, I will try with --disable-shared --enable-static later this weekend.

> BTW, I would like to see the output from make when it creates 
> libsane.la.  Hopefully, you can email it to me from above request.  I 
> want to make sure -no-undefined is there (which is required on Windows 
> and I think OS/2 fore DLL creation to be possible).

Should be included. Let me know if you need more content.


More information about the sane-devel mailing list