[sane-devel] Has anyone managed to get Snapscan backend working with FreeBSD 8.0 (which uses libusb)?

Torfinn Ingolfsen tingox at gmail.com
Mon Jan 25 11:26:12 UTC 2010


On Sun, Jan 24, 2010 at 9:51 PM, Oliver Schwartz <Oliver.Schwartz at gmx.de>wrote:

> what does you snapscan.conf look like? If libusb is used, you mustn't use a
> device entry such as "/dev/..." or "libusb:/dev/...". All that is needed is
> the entry containing the vendor and product ID of your scanner, i.e
> "usb 0x06bd 0x2061" and the firmware entry.
My snapscan.conf is correct, it only contains the firmware line and vendor
and product ID, sorry for not mentioning this in my first posting.

In the meantime, another FreeBSD user found a way to fix it, it is just a
one-line patch:

With Andrew's patch, my scanner now works:
 root at kg-v2# sane-find-scanner -q
found USB scanner (vendor=0x03f0 [HP], product=0xc202 [Photosmart 8200
series]) at libusb:/dev/usb:/dev/ugen1.2
found USB scanner (vendor=0x06bd [AGFA], product=0x2061 [ Snapscan1212u_2])
at libusb:/dev/usb:/dev/ugen2.2
root at kg-v2# scanimage -L
device `snapscan:libusb:/dev/usb:/dev/ugen2.2' is a AGFA SNAPSCAN 1212U_2
flatbed scanner

and also as a normal user:
tingo at kg-v2$ scanimage -L
device `snapscan:libusb:/dev/usb:/dev/ugen2.2' is a AGFA SNAPSCAN 1212U_2
flatbed scanner

Torfinn Ingolfsen
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20100125/d50caed9/attachment.htm>

More information about the sane-devel mailing list