<br><br><div class="gmail_quote">On Wed, Feb 25, 2009 at 11:08 PM, stef <span dir="ltr">&lt;<a href="mailto:stef.dev@free.fr">stef.dev@free.fr</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
<br><div class="Ih2E3d"><br>
</div>        Hello,<br>
<br>
        I would have preferred to ear of that change before. It comes at a wrong time<br>
since I&#39;m doing and testing a non-trivial merge in the genesys backend.<br>
<br>
        I didn&#39;t see any warning of such a global change. Did I miss an email ?</blockquote><div><br>Sorry about that... I bounced the idea off a few people but didn&#39;t submit to mailing list before I did it.  I think running the following commands should allow you to recover relatively easy (also its the easy way to revert my commit if it comes to it). <br>
<br>Run them should cause most the cvs update to say changes are already applied.  Or at least it can be used to update your genesys files and let you drop into a new copy of CVS to skip update step.<br><br>sed -i &#39;s/u_int8_t/uint8_t/g&#39; *.[ch] <br>
sed -i &#39;s/u_int16_t/uint16_t/g&#39; *.[ch] <br>sed -i &#39;s/u_int32_t/uint32_t/g&#39; *.[ch] <br><br><br></div><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
<br>
<br>
        However the &#39;right&#39; type to use is an interesting point, I&#39;ve never been<br>
really convinced with the mix of SANE_Int, int and u_int16 variables.</blockquote><div><br>I&#39;ll not speak for SANE_Int as it may have a special purpose.  For the rest, I usually don&#39;t mind to support a range of types that people are comfortable with.  Its just the u_int*_t are a BSD-ism and have portability issues; whereas uint*_t are now defined by C standard and should be easier to port (although stdint.h does have a suprisingly large amount of baggage itself).<br>
<br>I purposely left in the u_char_t, u_int_t, and u_long_t since they are not defined by same standard and do not have same portability issues for what ever reasons.<br></div></div><br>Chris<br>