[Secure-testing-team] wheezy in lib/python/debian_support.py?

Dominic Hargreaves dom at earth.li
Thu Feb 10 18:18:27 UTC 2011


I wanted to add an entry referencing wheezy regarding CVE-2011-0283
(it's not affected) but my commit was blocked:

svn: Commit blocked by pre-commit hook (exit code 1) with output:
  File "/srv/alioth.debian.org/chroot/home/groups/secure-testing/repo/lib/python/bugs.py", line 67, in __init__
    raise ValueError, "invalid release"
ValueError: invalid release

This is a trivial fix in lib/python/debian_support.py; would there
be any problem with me committing this?

Index: lib/python/debian_support.py
--- lib/python/debian_support.py        (revision 15437)
+++ lib/python/debian_support.py        (working copy)
@@ -177,7 +177,7 @@
 def listReleases():
     releases = {}
-    rels = ("potato", "woody", "sarge", "etch", "lenny", "squeeze", "sid")
+    rels = ("potato", "woody", "sarge", "etch", "lenny", "squeeze", "wheezy", "sid")
     for r in range(len(rels)):
         releases[rels[r]] = Release(rels[r], r)
     Release.releases = releases


Dominic Hargreaves | http://www.larted.org.uk/~dom/
PGP key 5178E2A5 from the.earth.li (keyserver,web,email)

More information about the Secure-testing-team mailing list