[Tux4kids-tuxtype-dev] meet a problem

David Bruce davidstuartbruce at gmail.com
Sun Jan 10 13:28:10 UTC 2010

Hi Gus,

On 1/10/10, gus cholis <guscholis at gmail.com> wrote:
> hallo Mr. David,
> when I configure tuxtype2-1.7.4 in my jaunty ubuntu, found:
> configure: error: SDL version 1.2.0 not found! http://www.libsdl.org
> is there a solution for me?

I assume you want a newer version because Jaunty has 1.5.17 (that is,
early 2008).

1. I'd suggest getting tuxtype-1.8.0 from our website

2. You need the so-called "-dev" versions of the libs that have all
the needed headers.  Do "sudo apt-cache search sdl" and look for the
-dev packages for libsdl, libsdl-mixer, libsdl-image, and
libsdd-pango, and install them with apt-get. Or use the gui package
installer (Synaptic).

3.  If you build 1.8.0, you need to use "./configure
--without-librsvg" unless you happen to have the -dev packages for
rsvg and cairo installed.

The file doc/INSTALL in the tarball explains all this.

Hope this helps,

David Bruce

More information about the Tux4kids-tuxtype-dev mailing list