[Virtual-pkg-base-maintainers] Bug#552546: base: bash/m4 buggy in squeeze

Philip Ashmore contact at philipashmore.com
Tue Oct 27 05:44:57 UTC 2009

Package: base
Severity: important

I just upgraded to squeeze amd64 from lenny.

I tried to rebuild my "v3c" package 
but I'm getting strange errors that I didn't get on lenny.

1. bash seems to have undergone a semantics change
   - code that worked in Lenny now doesn't.
   In the "fn" script I had to change
       if ! which libtoolize &>/dev/null ; then
       libtool --version &>/dev/null || {
   because bash is executing it in a different way than before.

2. m4 doesn't process like it used to (this could be a bash bug too)
       configure.ac:72: error: AC_SUBST: `DX_DONTJOIN(DX_FLAG_,DX_CURRENT_FEATURE)' is not a valid shell variable name

Obviously bash/m4 are "working", otherwise I wouldn't be ablt to get this far.
Have bash/m4 changed significantly in squeeze?

-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.30-2-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_IE.UTF-8, LC_CTYPE=en_IE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

More information about the Virtual-pkg-base-maintainers mailing list