Bug#546719: freecad needs pivy which is not available

David Goodenough david.goodenough at btconnect.com
Tue Sep 15 10:18:14 UTC 2009

Subject: freecad needs pivy which is not available
Package: freecad
Version: 0.8.2237-1
Severity: important

*** Please type your report below this line ***

When I try to go into the 2D Draw workbench, freecad tries to load pivy and it
can not find it.  It is not a dependency, and as far as I can tell is not 
available as a Debian package.  Freecad seems to recommend python-pivy, but
this does not exist, and as the 2D Draw workbench is somewhat fundamental to
using freecad it would seem that it should be a dependency not a 

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)

Kernel: Linux 2.6.30-1-686 (SMP w/1 CPU core)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages freecad depends on:
ii  libatk1.0-0        1.26.0-1              The ATK accessibility toolkit
ii  libavcodec52       5:0.5+svn20090823-0.0 library to encode decode 
ii  libavformat52      5:0.5+svn20090823-0.0 ffmpeg file format library
ii  libavutil49        4:0.5+svn20090706-2   ffmpeg utility library
ii  libboost-filesyste 1.39.0-5              filesystem operations (portable 
ii  libboost-program-o 1.39.0-4              program options library for C++
ii  libboost-regex1.39 1.39.0-5              regular expression library for 
ii  libboost-signals1. 1.39.0-5              managed signals and slots library 
ii  libboost-system1.3 1.39.0-5              Operating system (e.g. 
ii  libc6              2.9-26                GNU C Library: Shared libraries
ii  libcairo2          1.8.8-2               The Cairo 2D vector graphics 
ii  libcoin60          3.1.0-2               high-level 3D graphics kit 
ii  libcv1             1.0.0-6.2             computer vision library
ii  libcvaux1          1.0.0-6.2             computer vision extension library
ii  libfontconfig1     2.6.0-4               generic font configuration 
ii  libfreetype6       2.3.9-5               FreeType 2 font engine, shared 
ii  libgcc1            1:4.4.1-3             GCC support library
ii  libgl1-mesa-glx [l 7.5-3                 A free implementation of the 
ii  libglib2.0-0       2.20.5-1              The GLib library of C routines
ii  libglu1-mesa [libg 7.5-3                 The OpenGL utility library (GLU)
ii  libgtk2.0-0        2.16.6-1              The GTK+ graphical user interface 
ii  libgts-0.7-5       0.7.6+darcs090508-1   library to deal with 3D 
ii  libhighgui1        1.0.0-6.2             computer vision GUI library
ii  libice6            2:1.0.5-1             X11 Inter-Client Exchange library
ii  libjasper1         1.900.1-6             The JasPer JPEG-2000 runtime 
ii  libjpeg62          6b-15                 The Independent JPEG Group's JPEG 
ii  libopencascade-fou 6.3.0.dfsg.1-4        OpenCASCADE CAE platform shared 
ii  libopencascade-mod 6.3.0.dfsg.1-4        OpenCASCADE CAE platform shared 
ii  libpango1.0-0      1.24.5-1              Layout and rendering of 
ii  libpng12-0         1.2.39-1              PNG library - runtime
ii  libqt4-network     4:4.5.2-2             Qt 4 network module
ii  libqt4-opengl      4:4.5.2-2             Qt 4 OpenGL module
ii  libqt4-qt3support  4:4.5.2-2             Qt 3 compatibility library for Qt 
ii  libqt4-svg         4:4.5.2-2             Qt 4 SVG module
ii  libqt4-xml         4:4.5.2-2             Qt 4 XML module
ii  libqtcore4         4:4.5.2-2             Qt 4 core module
ii  libqtgui4          4:4.5.2-2             Qt 4 GUI module
ii  libsm6             2:1.1.1-1             X11 Session Management library
ii  libsoqt4-20        1.4.2~svn20090224-2   Qt4 GUI component toolkit for 
ii  libstdc++6         4.4.1-3               The GNU Standard C++ Library v3
ii  libswscale0        5:0.5+svn20090823-0.0 ffmpeg video scaling library
ii  libtiff4           3.9.1-1               Tag Image File Format (TIFF) 
ii  libx11-6           2:1.2.2-1             X11 client-side library
ii  libxerces-c28      2.8.0+deb1-2          validating XML parser library for 
ii  libxext6           2:1.0.4-1             X11 miscellaneous extension 
ii  libxi6             2:1.2.1-2             X11 Input extension library
ii  libxmu6            2:1.0.4-2             X11 miscellaneous utility library
ii  libxt6             1:1.0.6-1             X11 toolkit intrinsics library
ii  python             2.5.4-2               An interactive high-level 
ii  python-support     1.0.3                 automated rebuilding support for 
ii  python2.5          2.5.4-1               An interactive high-level 
ii  zlib1g             1:     compression library - runtime

Versions of packages freecad recommends:
pn  python-pivy                   <none>     (no description available)

Versions of packages freecad suggests:
pn  gnochm | kchmviewer | kchmvie <none>     (no description available)
pn  python-opencv                 <none>     (no description available)

-- no debconf information

More information about the debian-science-maintainers mailing list