[Freedombox-discuss] corrupt FS inside image ? - Was: Re: FreedomBox Unstable Image 2012.1021 Available

Nick M. Daly nick.m.daly at gmail.com
Sat Nov 10 20:09:26 UTC 2012

Olivier Berger writes:
> "Nick M. Daly" writes:
>> Olivier Berger writes:
>>> I've tried and install the contents of the
>>> freedombox-unstable_2012.1021_dreamplug-armel-card.img image to a 4GB
>>> SD card, which was previously partitioned.
>>> I've tried using kpartx to locally mount the contents of the immage
>>> without success...
>> Just use dd.  See the "To Use It" section of FreedomMaker's README [0]
>> to load the image on to the DreamPlug's internal microSD card.
> OK, I can do that... but still... what if the contents of the image is
> broken ? Normally, I'd expect the FS image to be mountable, right ?

It works fine over losetup and mount.

# losetup /dev/loop0 freedombox-unstable_2012.1021_dreamplug-armel-card.img

# mount /dev/loop0 -t ext2 -o offset=135266304 /media/freedom/

The offset is 128 MiB + 1 MiB (in bytes), which is the start of the ext2
partition.  To mount the 128 MiB FAT partition, specify an offset of 1

# umount /media/freedom/

# losetup -d /dev/loop0

> Is there a test of the partition's FS before generating the image ?

Yup.  The image is created from a formatted SD card to (hopefully) preclude
partition issues.

>> If you don't have access to a JTAG some of the older images will boot
>> smoothly on the DreamPlug's default bootloader, but I don't recall which
>> image exactly broke it (I think it was one of the 2012.07* images?).
> Yeah, that's the point... there doesn't seem to be some documentation
> about which image works for which hardware in the (debian) wiki,
> unfortunately.

Feel free to start one.  I'm trying to finish other work this weekend.
The information you need follows:

There are at least two known versions of DreamPlugs that are somewhat
incompatible (the wireless hardware is different, IIRC).  I do not
believe these hardware differences affect whether the DreamPlug boots.

You can tell which DreamPlug version you have by reading the serial

- DS2-1112 :: Initial DreamPlug release.
- DS2-1113 :: Updated DreamPlug release.

If other DreamPlug series exist, they are unknown to me, so I can't
speak to their ability to boot images.

The uboot version (and its configuration) as delivered on the plug
affect what images it can boot.  Vendors configure uboot differently, so
all I can speak to is DreamPlugs delivered by GlobalScale, because those
are the only ones I've had experience with.  In other words, image
booting incompatibilities are related to the uboot version and
configuration on the plug itself.

- Images before the 0.1 release boot smoothly on stock DreamPlugs from

- Images on or after the 0.1 release (2012-0820) need the 2012.04.01 or
  later version of uboot from Debian Wheezy.

Here're the tables you're looking for.  Please put them on the wiki.

| Vendor      | Model    | uboot   |
| GlobalScale | DS2-1112 | Default |
| GlobalScale | DS2-1113 | Default |

| uboot Vendor | uboot Version       | Image Versions    |
| GlobalScale  | The Default (?)     | Pre 0.1           |
| Debian       | 2012.04.01 (Wheezy) | Pre 0.1, Post 0.1 |

Bdale has not, to my knowledge, published any images himself.  The
weekly images considered "Pre 0.1" are the 2012.0819 image and prior
images.  The "Post 0.1" images are the 2012.0903 image and later images.

The only non-DreamPlug hardware I can speak to is the GuruPlug.  The
GuruPlug will boot images built with these makefile options:

    make MACHINE=guruplug plugserver-image

And that's all I know on the subject.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 835 bytes
Desc: not available
URL: <http://lists.alioth.debian.org/pipermail/freedombox-discuss/attachments/20121110/e3c60cf6/attachment.pgp>

More information about the Freedombox-discuss mailing list