Bug#467003: libmodule-scandeps-perl: uninstallable and unbuildable with Perl 5.10

Niko Tyni ntyni at debian.org
Fri Feb 22 12:13:24 UTC 2008

Package: libmodule-scandeps-perl
Version: 0.82-2
Severity: important
User: debian-perl at lists.debian.org
Usertags: perl-5.10-transition

The libmodule-scandeps-perl package has a versioned {,build-}dependency
on libmodule-build-perl (>= 0.28), but perl-modules 5.10.0-3 (currently
in experimental) has

Replaces: libmodule-build-perl
Provides: libmodule-build-perl
Conflicts: libmodule-build-perl (<< 0.2808.1-1)

as it includes Module::Build 0.2808_01.

This makes libmodule-scandeps-perl uninstallable and unbuildable with
Perl 5.10, as provided packages don't satisfy versioned dependencies.

The versioned dependency is necessary: it's present for
Module::Build::ModuleInfo, introduced in Module::Build 0.27_01.

The best solution I can think of is

 Depends: libmodule-build-perl
 Conflicts: libmodule-build-perl (<< 0.28)

 Build-Depends-Indep: libmodule-build-perl
 Build-Conflicts-Indep: libmodule-build-perl (<< 0.28)

Suggestions welcome. There are six other packages in the archive that have
a versioned build-dependency on Module::Build, but libmodule-scandeps-perl
is the only one that has a runtime dependency too.

Niko Tyni   ntyni at debian.org

More information about the pkg-perl-maintainers mailing list