[SCM] WebKit Debian packaging branch, debian/unstable, updated. debian/1.1.15-1-40151-g37bb677

cblu cblu at 268f45cc-cd09-0410-ab3c-d52691b4dbfc
Sat Sep 26 07:21:01 UTC 2009


The following commit has been merged in the debian/unstable branch:
commit 0c65f9c19ce9f0114e732454c1e212cee9f07b2e
Author: cblu <cblu at 268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Date:   Wed Jan 22 18:53:30 2003 +0000

    	Renamed isPointSelected to isPointInsideSelection because it's a better name.
    
            Reviewed by darin.
    
            * khtml/khtml_part.cpp:
            (KHTMLPart::isPointInsideSelection):
            (KHTMLPart::khtmlMousePressEvent):
            * khtml/khtml_part.h:
            * kwq/WebCoreBridge.mm:
            (-[WebCoreBridge elementAtPoint:]):
    
    
    git-svn-id: http://svn.webkit.org/repository/webkit/trunk@3398 268f45cc-cd09-0410-ab3c-d52691b4dbfc

diff --git a/WebCore/ChangeLog-2003-10-25 b/WebCore/ChangeLog-2003-10-25
index 7811f02..452c759 100644
--- a/WebCore/ChangeLog-2003-10-25
+++ b/WebCore/ChangeLog-2003-10-25
@@ -1,3 +1,16 @@
+2003-01-22  Chris Blumenberg  <cblu at apple.com>
+
+	Renamed isPointSelected to isPointInsideSelection because it's a better name.
+
+        Reviewed by darin.
+
+        * khtml/khtml_part.cpp:
+        (KHTMLPart::isPointInsideSelection): 
+        (KHTMLPart::khtmlMousePressEvent):
+        * khtml/khtml_part.h:
+        * kwq/WebCoreBridge.mm:
+        (-[WebCoreBridge elementAtPoint:]):
+
 2003-01-21  Chris Blumenberg  <cblu at apple.com>
 
 	Added support for text dragging.
diff --git a/WebCore/ChangeLog-2005-08-23 b/WebCore/ChangeLog-2005-08-23
index 7811f02..452c759 100644
--- a/WebCore/ChangeLog-2005-08-23
+++ b/WebCore/ChangeLog-2005-08-23
@@ -1,3 +1,16 @@
+2003-01-22  Chris Blumenberg  <cblu at apple.com>
+
+	Renamed isPointSelected to isPointInsideSelection because it's a better name.
+
+        Reviewed by darin.
+
+        * khtml/khtml_part.cpp:
+        (KHTMLPart::isPointInsideSelection): 
+        (KHTMLPart::khtmlMousePressEvent):
+        * khtml/khtml_part.h:
+        * kwq/WebCoreBridge.mm:
+        (-[WebCoreBridge elementAtPoint:]):
+
 2003-01-21  Chris Blumenberg  <cblu at apple.com>
 
 	Added support for text dragging.
diff --git a/WebCore/khtml/khtml_part.cpp b/WebCore/khtml/khtml_part.cpp
index 409af1f..7c5e035 100644
--- a/WebCore/khtml/khtml_part.cpp
+++ b/WebCore/khtml/khtml_part.cpp
@@ -4116,7 +4116,7 @@ static void findWordBoundary(QChar *chars, int len, int position, int *start, in
 }
 #endif
 
-bool KHTMLPart::isPointSelected(int x, int y)
+bool KHTMLPart::isPointInsideSelection(int x, int y)
 {
     if (!xmlDocImpl()->renderer()) {
         return false;
@@ -4293,7 +4293,7 @@ void KHTMLPart::khtmlMousePressEvent( khtml::MousePressEvent *event )
 #if APPLE_CHANGES
                 // Don't restart the selection when the mouse is pressed on an
                 // existing selection so we can allow for text dragging.
-                if (isPointSelected(event->x(), event->y())) {
+                if (isPointInsideSelection(event->x(), event->y())) {
                     return;
                 }
 #endif
diff --git a/WebCore/khtml/khtml_part.h b/WebCore/khtml/khtml_part.h
index 6bcd8ad..cb7cd0a 100644
--- a/WebCore/khtml/khtml_part.h
+++ b/WebCore/khtml/khtml_part.h
@@ -707,7 +707,7 @@ public:
    */
   void preloadScript(const QString &url, const QString &script);
 
-  bool isPointSelected(int x, int y);
+  bool isPointInsideSelection(int x, int y);
 
   /**
    * @internal
diff --git a/WebCore/kwq/WebCoreBridge.mm b/WebCore/kwq/WebCoreBridge.mm
index 5b4e7f9..d411af0 100644
--- a/WebCore/kwq/WebCoreBridge.mm
+++ b/WebCore/kwq/WebCoreBridge.mm
@@ -437,7 +437,7 @@ static bool initializedObjectCacheSize = FALSE;
     renderer->layer()->nodeAtPoint(nodeInfo, (int)point.x, (int)point.y);
     
     NSMutableDictionary *element = [NSMutableDictionary dictionary];
-    [element setObject:[NSNumber numberWithBool:_part->isPointSelected((int)point.x, (int)point.y)]
+    [element setObject:[NSNumber numberWithBool:_part->isPointInsideSelection((int)point.x, (int)point.y)]
                 forKey:WebCoreElementIsSelectedTextKey];
     
     NodeImpl *URLNode = nodeInfo.URLElement();

-- 
WebKit Debian packaging



More information about the Pkg-webkit-commits mailing list